Mycroft Community Forum

Speak not working

Hi, I had some problems with the docker image so I used the instructions for Linux setup inside an Ubuntu server VM on VirtualBox. I have everything working, logs, cli, audiotest works, and I hear the bell when I say ‘hey mycroft’… except there is no audio output when using the speak skill. The audio log has a clue, it says "File…speech.py … tts.playback.stop AttributeError: ‘nonetype’ object has no attribute 'playback '.

Any ideas?

It looks like the object tts does not have a playback programmed to it. I don’t know if that is a bug, or if a device isnt connecting and leaving the playback attribute empty. I dont think I messed with the tts settings on this install, so I’m thinking its a code bug?

Also, I dont think this is relevant, but could be… the /var/log/mycroft directory wasnt created initially, so I made it.

Oh, and the copy button on the help docs, example link below, isnt working on Firefox on Kubuntu 20.04. Audio Troubleshooting - Mycroft AI

means that no tts was defined (/tts class created as a consequence). But i have too little knowledge about mycroft docker. (how it is preconfigured) Usually (with the linux install) you are questioned if you want to build mimic, at which the default conf is pointing to - and if not you are pointed at mimic2.

I guess the user conf (/the whole user config directory) is to be mapped somewhere outside and then defined like that

@SGee Thanks so much… I had mycroft set up a year ago and forgot about the config file. I do think I installed Mimic when setting up, but installing espeak worked after setting the config. So your advice was spot on, thanks.