Mycroft Community Forum

Spotify Connect/Authorize does not work

In Mycroft advanced skill settings, when i go on the spotify skill, click “Connect”, log into my spotify account then i get the following error message:

INVALID_CLIENT: Failed to get client

Can anyone help? This happens with different devices and different browsers, i suppose something with the base_URI is off, but no idea how to fix it :slight_smile:

Many thanks!
Your Spotify Struggler :slight_smile:

Edit: I am living in Europe and therefore have an European Spotify account, does that matter?

2 Likes

I believe spotify continues to be an issue. See here.

2 Likes

Front line support is fairly useless on this. I’d love to be able to help figure this out. Can someone on the Mycroft dev team check to see if their app is still authorized? INVALID_CLIENT seems to point to the request being rejected by Spotify because it doesn’t trust the client id that we’re returning to them for the auth request.

2 Likes

i too see the exact same error. looks like the the client ID (client_id=5509ac5c42cc45d7b4625d0b851a0f1e) on the redirect from the connect button in the spotify skill is no longer valid? Would love to get an answer to Tatorzot and others question on this from the devs. tx!

1 Like

I followed these steps: https://github.com/forslund/spotify-skill/issues/152#issuecomment-719563633

And added a comment with the missing ones: https://github.com/forslund/spotify-skill/issues/152#issuecomment-734514422

At the end all is working fine for me.

I’m running this on mac with virtual box so I don’t think the github fix will work for me. Please fix spotify connect :pleading_face:

The GitHub fix should work for you.