Start-mycroft.sh: command not found


#1

Running Kubuntu

KDE Version 5.12.7

KDE frameworks version 5.44.0

Kernel: 4.18.0-17

64 bit

2x Intel Core 2 Duo CP T5750, 4 GB of RAM.


Have been trying to install the desktop version of Mycroft and have been receiving the same error. Trying looking into the documentation and following YouTube videos, but am stuck as I keep receiving the following error:

start-mycroft.sh: command not found

Any help would be appreciated. Thank you in advance!


#2

Hi there,

Can I ask what steps you took before trying to run start-mycroft.sh?

For Kubuntu, you should only have to run a few commands:

  1. cd ~/
  2. git clone https://github.com/MycroftAI/mycroft-core.git
  3. cd mycroft-core
  4. bash dev_setup.sh
  5. ./start-mycroft.sh debug

Is that what you’ve already tried so far?


#3

for some reason I didn’t see the “debug” part of that code in my research.

Seems to be working now!

Trying to figure out how to install the visual interface. I found this:

I got up to line 25, but I’m lost from there.


#4

Got it to work haha

working on building new skills at the moment


#5

Great to hear!

Was there anything specific you had to change, in case others run into the same problem?


#6

`Yes, typing in the following:

./start-mycroft.sh debug

as opposed to just ./start-mycroft.sh (this didn’t work for me)

Not sure why that is to be honest.

I’ve also tried downloading skills directly from the website (in my account) but that doesn’t seem to work.

Is this normal?

Or does the fact that I’m using a desktop/laptop mean that I have to download the skills via github/linux terminal?


#7

I’ve also noticed that the time Mycroft gives me is an hour behind.

Any idea why this is?


#8

Check the timezone/daylight saving time settings of your operating system.


#9

I checked the time zone tab: showing the correct time zone.

Desktop panel shows correct time(and time zone) as well.


#10

Added the location on my account online and that seemed to fix the problem!


#11

Hey, we had some issues with Home over the weekend that have now been resolved (big thanks to Matheus and Ake working overtime this weekend) so let me know if you still can’t install via the website.

The timezone is currently taken from your account rather than your local device so that will have been the issue there.