Start-mycroft.sh: command not found


#1

Running Kubuntu

KDE Version 5.12.7

KDE frameworks version 5.44.0

Kernel: 4.18.0-17

64 bit

2x Intel Core 2 Duo CP T5750, 4 GB of RAM.


Have been trying to install the desktop version of Mycroft and have been receiving the same error. Trying looking into the documentation and following YouTube videos, but am stuck as I keep receiving the following error:

start-mycroft.sh: command not found

Any help would be appreciated. Thank you in advance!


#2

Hi there,

Can I ask what steps you took before trying to run start-mycroft.sh?

For Kubuntu, you should only have to run a few commands:

  1. cd ~/
  2. git clone https://github.com/MycroftAI/mycroft-core.git
  3. cd mycroft-core
  4. bash dev_setup.sh
  5. ./start-mycroft.sh debug

Is that what you’ve already tried so far?


#3

for some reason I didn’t see the “debug” part of that code in my research.

Seems to be working now!

Trying to figure out how to install the visual interface. I found this:

I got up to line 25, but I’m lost from there.


#4

Got it to work haha

working on building new skills at the moment


#5

Great to hear!

Was there anything specific you had to change, in case others run into the same problem?


#6

`Yes, typing in the following:

./start-mycroft.sh debug

as opposed to just ./start-mycroft.sh (this didn’t work for me)

Not sure why that is to be honest.

I’ve also tried downloading skills directly from the website (in my account) but that doesn’t seem to work.

Is this normal?

Or does the fact that I’m using a desktop/laptop mean that I have to download the skills via github/linux terminal?


#7

I’ve also noticed that the time Mycroft gives me is an hour behind.

Any idea why this is?


#8

Check the timezone/daylight saving time settings of your operating system.


#9

I checked the time zone tab: showing the correct time zone.

Desktop panel shows correct time(and time zone) as well.


#10

Added the location on my account online and that seemed to fix the problem!


#11

Hey, we had some issues with Home over the weekend that have now been resolved (big thanks to Matheus and Ake working overtime this weekend) so let me know if you still can’t install via the website.

The timezone is currently taken from your account rather than your local device so that will have been the issue there.


#12

@gez-mycroft, I’m just seeing this now so I’ll try to still skills from the website!

Some skills are currently installing as I write this message and I’ll test accordingly.

I have noticed as of recently that Mycroft doesn’t respond to my voice commands like it used to. My device is a laptop running Kubuntu (has all the latest updates). When using the Mycroft applet for plasma desktop, the Mycroft doesn’t respond as it has it in the past using the “Hey, Mycroft” command.

Now, I have to press the large microphone button or type in requests.

I thought this might be a internal microphone issue, so I used the Audacity application to test to see if something is wrong with my internal microphone; it records my sound, although it is lower than it was about two months ago, when I tested it last.

That said, being that Mycroft can hear me when I press the large microphone button on the applet, I don’t know if this a hardware issue.

I edited this comment to try to be more thorough, so please don’t hesitate to let me know if you need any additional information (and/or whether I should create a new thread for this).


#13

Hmm I think it’s most likely not a hardware issue. You wouldn’t be the first person to have issues with your microphone, though interesting that it works if you hit the button. So Mycroft is detecting and using your mic, it’s just the wake word spotting not working as expected.

If you open a terminal and open the CLI interface by using the command:
mycroft-cli-client
In the bottom right of this screen should be a mic level bouncing around as you talk. Is that the case or does it only change when you hit the button on the applet?

Also worth trying:
mycroft-start all restart
This just forces a restart of all the Mycroft services which can sometimes resolve these intermittent mic issues.


#14

I did the " mycroft-start all restart" and once I did that, I was able to see the mic bounce around in the “mycroft-cli-client

That said, the issue is still happening.

So Mycroft is detecting and using your mic, it’s just the wake word spotting not working as expected.

Essentially, I believe this is the main issue.

In the bottom right of this screen should be a mic level bouncing around as you talk. Is that the case or does it only change when you hit the button on the applet?

It does bounce around in the CLI interface, but it still doesn’t wake with the word spotting. As far as the applet, large button works, but the word waking doesn’t work. I tested this after the reset.


#15

In that case, there’s an immediate answer and a slightly longer-term answer.

In not very long we’re releasing an update to our wake word system that will significantly improve it’s ability to detect different voices. So if you’re happy hitting the button for the moment then I’d hold out for that.

If you’re keen to try new things and get it working, you can head to your Advanced Settings in Home. I’d first try some of the other pre-configured wake words to see if they perform better with your voice. Or you can choose ‘Custom’, copy the “Hey Mycroft” values across, and slightly reduce the threshold for activation. This takes some trial and error to tweak and find an appropriate value.

There’s more on the available Advanced Settings in our documentation.


#16

In not very long we’re releasing an update to our wake word system that will significantly improve it’s ability to detect different voices. So if you’re happy hitting the button for the moment then I’d hold out for that.

I really appreciate the response. I might just hold off till this goes through. Any idea on the timeline?


#17

Mmm, I was intentionally vague as I don’t like giving dates and disappointing but… should be this month.