Starting Mycroft automatically


#1

Maybe by typing my problem here it will fix itself like my mic/speaker problem.

Another problem I have is getting Mycroft to start upon bootup on Ubuntu. I used the commands here: https://mycroft.ai/documentation/mycroft-for-macos-and-windows-with-virtualbox/

I get a file not found/no such command type error. When I type it in after bootup it works fine.

I have Unbuntu Server on VBox in Windows 7

Regards,
Athena


#2

That will only start it when a command shell is opened.

You’d have to search how to add a system startup command with systemd for running “/home/me/mycroft-core/start-mycroft.sh debug”


#3

Thanks for flagging that one, I’ve taken it off the docs for now.


#4

This may help: https://github.com/MycroftAI/enclosure-picroft/blob/stretch/image_recipe.md
I followed this recipe today to start Mycroft automatically after boot in an Orange Pi Zero, specifically the part where you create a service to spin a headless terminal:

Enable Autologin as the ‘pi’ user (change it for your user)

sudo nano /etc/systemd/system/getty@tty1.service.d/autologin.conf and enter:

[Service]
ExecStart=
ExecStart=-/sbin/agetty --autologin pi --noclear %I     38400 linux

save, exit nano and enable the new service with:

sudo systemctl enable getty@tty1.service

And the part where you create an entry in .bashrc to start Mycroft:

[Customize .bashrc for startup](https://github.com/MycroftAI/enclosure-picroft/blob/stretch/image_recipe.md#customize-bashrc-for-startup)

nano ~/.bashrc uncomment #alias ll='ls -l' near the bottom of the file at the bottom add:

#####################################
# This initializes Mycroft
#####################################
source ~/auto_run.sh

You may want to tweak auto_run.sh though, as it is aimed for raspberry Pi.


#5

Thanks. :slight_smile: I will try that.