Mycroft Community Forum

Startup wizard stalls if already connected to WiFi

I progressed all the way through the startup wizard on my Mark 1 to the point where Mycroft wanted to register itself. I had issues registering an account at home.mycroft.ai (now resolved), but then I had turned off Mycroft, so I powered it back up again.

When connected via the MYCROFT WiFi access point, it wanted me to select a WiFi network to connect to and supply a network for; my WiFi network was already connected, so Mycroft didn’t present me with a box to put the password in. That box seems to also comes with the “next” arrow, which was not displayed on my WiFi network. As a result, I could not proceed any further.

The workaround was to reset Mycroft and start from scratch. However, if there were a “proceed” arrow on any existing WiFi network for which it had a working key, I could have continued from there.

I had hard time setting up mark1 and had similar issue.

I’ve had this problem twice in the last week, testing the Mark I in new (as in, Mycroft had never connected before) wireless networks. Any updates on this?

Hi @lauriehannon we would need more information to help diagnose the issue.

  • What sort of WiFi authentication do you use - ie WPA-PSK?
  • Does the name of the SSID contain any non-Latin characters?
  • Can you provide the name of your router - there are some brands in particular which can be problematic.

Hi @KathyReid, thanks for the quick response.

The routers belong to corporations – I don’t have physical access nor administrative rights, so I don’t know what the brands are nor what authentication they are using. Neither of the networks I was having trouble connecting Mycroft to had non-Latin characters in their names.

My dilemma is this: I am preparing to demo Mycroft at a session at OSCON next month. I don’t know what wi-fi router models will be available to me nor which authentication they’ll be using. Worst case is I won’t have enough time to troubleshoot connection problems before the session to have a live working demo. I’ve been testing setting my Mark I up in networked environments it has never connected to in order to practice troubleshooting and maybe reduce setup time.

My plan B for the session is to show videos of Mycroft working in my home environment. But I’d much rather show him off live in his best light. Do you have any advice for how best to get the Mark I connected successfully and quickly when walking into an environment with an unknown router?

Thanks,
Laurie

Thanks for the info @lauriehannon, totally understand the dilemma you’re in.

In this case, if OSCON is able to tell you the WiFi network details ahead of time, what I would recommend is pre-configuring the wpa_supplicant.conf file on the Mark 1 so that the details are loaded on the device before you get to OSCON.

This documentation is for wpa_supplicant.conf on Picroft, but should apply equally to the Mark 1:

Thanks, @KathyReid, I’ll see if I can get that info.

1 Like