Mycroft Community Forum

STT volume very low, how to increase it?

In my install the wake word is working perfectly but the STT is not. I have mycroft hooked up to a local deepspeech server. DS performance is great when tested standalone, with audiofiles fed to it directly but not when the audio comes from mycroft.

For debugging puposes i dumped the audio data that mycroft sends to the deepspeech server straight into a file. When played with aplay it works but is extremely quiet. Had to increase it with sox -v192 to get it into a reasonable volume range.

Since the wake word and audiotest work fine I believe something is happening to the audio in the STT-handling code only. But unlike with “precise”, i don’t see any config settings that would let me amplify the signal or anything related to volume at all. So I’m stuck…

If anybody has got a hint for me, let me know.

Turns out this was the volume-skills doing. I saw that another community member reported a similar issue last year: Mycroft muting audio after wakeword detected? - #11 by J_Montgomery_Mycroft
I didn’t see the same logging in my case so I thought it’s another issue. Turns out the loglevel for these messages changed to DEBUG…

In that thread the issue supposedly was due to the alarm skill but i can blacklist the alarm skill and the issue persists. It also looks like it’s just the VolumeSkill in the logs:

18:43:18.218 | INFO | 3800 | main:handle_record_begin:41 | Begin Recording…
18:43:18.245 | DEBUG | 3794 | VolumeSkill | MUTING!
18:43:18.245 | DEBUG | 3794 | VolumeSkill | Finding Alsa Mixer for control…
18:43:18.284 | DEBUG | 3794 | VolumeSkill | Volume before mute: 100
18:43:18.284 | DEBUG | 3794 | VolumeSkill | 100
18:43:18.284 | DEBUG | 3794 | VolumeSkill | 0
18:43:21.407 | DEBUG | 3794 | VolumeSkill | Finding Alsa Mixer for control…
18:43:21.469 | DEBUG | 3794 | VolumeSkill | 100

(after 3s it finished recording and unmuted the mic again)

If I blacklist the VolumeSkill, the issue disappears.
This might be some setup problem as I’ve never paired my installation, but then again I played with the two most obvious settings that could affect this, “mute_during_output” and “duck_while_listening” and they had no effect here. So I guess I’ll submit a bug report for this.