The Calendar skill


#21

Can you post the contents of the settings.json file in the calendar skill directory (With the sensitive parts blocked out, of course)


#22

Hummm, in which directory?
On /opt/mycroft/skills/calendar-skill.linuss1 there is no need to blur anything
settings.json

  {"__mycroft_skill_firstrun": false}

The other file on this very same location: settingsmeta.yaml

name: Calendar
skillMetadata:
  sections:
    - name: Calendar Location
      fields:
        - type: label
          label: By default, the calendar skill defaults to saving your calendar on your device. However, if you wish to connect to a iCal server, you can select the setting here then fill out the information below. You can also <a href='http://bit.ly/mycroft-calendar-ics'>learn more about ics files.</a>
        - name: server_type
          type: select
          label: Calendar Location
          value: "local"
          options: Locally on the device|local;iCal Server|server
    - name: iCal Login
      fields:
        - type: label
          label: <b>If you selected iCal Server</b> above, fill out the form here, to connect Mycroft to your iCal account. If you wish not to enter this information in here, you can <a href='https://bit.ly/mycroft-calendar-local'>configure the skill on your device</a>
        - name: username
          type: text
          label: Username
          value: ""
        - name: password
          type: password
          label: Password
          value: ""
        - name: port
          type: number
          label: Password
          value: ""
        - name: server_address
          type: text
          label: address
          value: ""

On ~/.mycroft/skills/Calendar there isn’t any file at all.

Where I put the configuration was in ~/.mycroft/calendar-skill.linuss1 with this content

username: <MY_NEXTCLOUD_USERNAME>
password: <MY_NEXTCLOUD_PASSWORD>
server_address: <MY_NEXTCLOUD_URL>
port: 443

It makes any sense for you?


#23

Okay, try putting the configuration that you entered (in ~/.mycroft/calendar-skill.linuss1) into a file, with the same name at ~/.mycroft/skills/Calendar and deleting the other.
Then try rebooting to make sure the changes take affect.

If that doesn’t work, delete the configuration files that you created (~/.mycroft/skills/Calendar) and try configuring with Mycroft home. Make sure you click the save button and then say “configuration update” to pull the settings down. Then check /opt/mycroft/skills/calendar-skill.linuss1/settings.json to see if your information was pulled down. (post that file here).