tornado.web.HTTPError: HTTP 404: Not Found


#1

I am facing exacly the same problem as described here: Conecting to the mycroft web client. I read this whole discussion but I can’t solve my problem. Mayby I don’t understand something or there is other solution?

Thank You!


#2

Hi there,

Welcome to the Community :slight_smile:

Can I clarify, you are trying to setup the Mycroft Web Client from @jcasoft and receiving the 404 response?

I’m not familiar with this package so can’t provide too much assistance, however I know the author still drops by the forums every now and then.

Is your Mycroft instance receiving the GET requests? There should be logs being written to /var/log/mycroft/bus.log


#3

Hi, thank you for reply!
Forget about my last post and I will start from the beginning. I saw this error for the first time after I opened port 8181 in the browser to check what’s on it and I found this:

Traceback (most recent call last):
File “/home/abc/mycroft-core/.venv/lib/python3.6/site-packages/tornado/web.py”, line 1390, in _execute
result = self.prepare()
File “/home/franciszek/mycroft-core/.venv/lib/python3.6/site-packages/tornado/web.py”, line 2103, in prepare
raise HTTPError(self._status_code)
tornado.web.HTTPError: HTTP 404: Not Found

I tought “this is not good” and without any reaserch I assumed that this need to be some type of web-client that is broken. Before comming accros this message-bus documentation: https://mycroft.ai/documentation/message-bus/, I found this: Conecting to the mycroft web client and relised that web-client is not installed and I have to do it manually, but I did not succed due to the outdated README.

Long-story short, after posting my last post I succed today in installing other web-client by the same author: https://github.com/jcasoft/Web-Chat-Client-for-Mycroft I needed to perform few modifications to get it working because it also is outdated. I will post this modyfications on issues of WebChatClient GitHub.

My final question is: Is it normall and expected to have this error after fresh installation?
I hope my english is good enough to understand me.

Thank You!


#4

Hey glad it’s working and thanks for contributing your findings back to the repo.

If you setup a fresh mycroft-core installation without changing anything you should not get a 404. Were you getting this before you changed anything?


#5

It was a fresh installation. When I ran “mycroft-start debug” I noticed that app was using port 8181. It wasn’t my first mycroft build. Before I build it few times but I always mess up something and rebuild it again (you know, I am learning). Before new build I removed: /opt/mycroft, ~/mycroft-core, ~/.minecroft and /usr/share/mycroft-core

I am running manjaro-cinnamon on Lenovo legion Y530