Trouble changing mycrofts name

Hello guys,

I am trying to change mycrofts name by following the documents at https://docs.mycroft.ai that “DarkSide” suggested me to follow.
by putting a few lines of code inside the /mycroft-core-master/mycroft/configuration directory and the mycroft.ini file.

// the code.
[listener]
wake_word = "hey hermes"
phonemes = "HH EY . HH ER M IY Z ."
threshold = “1e-90”

After restarting ./mycroft.sh it did not work. by calling him with his new name. however the default “hey mycroft” still works. does anyone have the same problem here? or have i missed the solution in a different topic.
mycroft is running on ubuntu 16.04LTS.

Thanks for advancing.
N.

Did you add it to the end of mycroft/configuration/mycroft.ini? I recommend adding it to the end of ~/./mycroft/mycroft.ini. If you want to modify the config file in the mycroft/configuration directory, you’ll have to replace the config options that are already there rather then adding it to the end.

Yes, i have added the code at the end of the mycroft/configuration/mycroft.ini.
Inside /mycroft-core-master/mycroft directory is no mycroft.ini file.

To have a better understanding what you are saying is,

  1. Do you mean that i have to create a new mycroft.ini with the new code inside the /mycroft-core-master/mycroft/configuration directory?
  2. if so, does that mean i have to put the other configurations with it?
  3. or just only that specific part of the code. wich means i have two mycroft.ini files inside the /mycroft-core-master/mycroft/configuration directory one with all standard configurations and the second file with just only the “listener” bit of code.
  4. Do i have to erase the old mycroft.ini file and just put a new mycroft.ini file with just the “listener” bit of code.

No, you wouldn’t create a new .ini file in the mycroft/configuration directory. You would create a new ~/,mycroft/mycroft.ini file with only the configuration changes that you want. In this case, it would be just the listener options. ~ here refers to the Linux home directory. For example, for me that would be /home/ethanw/.mycroft/mycroft.ini, since ~ for me is /home/ethanw. The reason to put it there instead of changing mycroft/configuration/mycroft.ini is that changes in that file override those in mycroft/configuration/mycroft.ini.

Alternatively, if you don’t want to deal with creating a new file, you could modify the mycroft/configuration/mycroft.ini file. In your case, you would just look in there for the [listener] heading and change those options to what you listed in your first post.

Finally understood, what you where trying to tell me.

One thing i noticed is that the [listener] part weren’t inside my mycroft/configuration/mycroft.ini file. in the first time i was looking into that file. Does that mean mycroft is outdated? if so, is there a way to easily update mycroft?.
i really appreciate your help ethanward, and fast response.

Yeah, talking about the config files can be a bit confusing. I’m glad you figured it out.

And yes, that would mean that mycroft is outdated. If you cloned our repo using git, updating it should just be as simple as running git pull. If you downloaded the .zip from the github page, I think the best way to update would be to start using git and clone the repository. That way you can easily update in the future. If you really want to, you can download the zip file of the latest release and re-run the setup scripts. You’ll have to do that every time you want to update though, so I wouldn’t recommend it.

@Goldsmith where did you learn how to compose the phonemes? I want to change my wakeword to “ElderBot” but have no idea how to put together the characters for the phonemes. I googled the topic but found nothing that looked like the 1-2 character scheme used by mycroft.

Hey David,

There are Documentations about configuring the “Mycroft core”.

https://docs.mycroft.ai/development/troubleshooting.notes

Is the part of how to set the phonemes to the name you desire.
good luck and enjoy!

greetings,

N

Thanks, @Goldsmith !