Mycroft Community Forum

Unable to use mymqttskills

Hello guys. I’m new to Mycroft and this is my first post.

I’m currently trying to use the MQTT skills provided by JamieHoward430 here. Before I try make major change in the init.py, I tried running the skills and when I say ‘turn the light_switch on’ (note that light_switch is the name of my actual device. I have also edited the host/broker, the name in the intent file and pretty much everything that is needed to connect to my broker.), it would reply;

The command turn off for light_switch was not understood by my m q t t.
The module light_switch doesn't exist.
The module light_switch is not found. Error 404.
The m q t t rejected me for turn on the light_switch.

May I know what’s causing this? Tried scouring the net for answer or possible solutions but found none. And please let me know if I’m not being clear or not providing enough information. I’ll gladly provide more. And sorry if my English is not too good as English is not my mother language. Thank you in advance everyone!