Mycroft Community Forum

Voice recognition does not work after mycroft upgrade

I recent perfomed mycroft upgrade.
After, rebooting, the voice recognition is nowr working. Also the led panel does not dispalay the hour or show any respone to wake up command or any other voice command

I used mycroft-cli-client… and any word phrase is captured, the debug client does nto display anything when send the wake up command or other voice command

You have to give more information about your system (software/hardware,…) although i suspect Mark1, yet my crystal ball is dusty.

Hi… it is Mark 1
I received the message, of “major mycroft is available” and send the yes to update.
This happened on sunday.

Below the mycroft version

mycroft-core/unknown,now 20.8.0 armhf [installed]
pi@mark_1:~ $

I am with stable branch, I verified using mycroft-use stable
Attached you will find the device (how it looks like). Commands outputs and log files!
As you could see no voice command is received in cli-client, also the device display led does not display when “hey mycroft” wake command is sent

You can check here

https://drive.google.com/drive/folders/1uKYIFjZYvvRTzHRSAmESLhckxbSFMU5b?usp=sharing

mark1|678x500

Hey Grover, welcome to the forums :slight_smile:

Sorry to hear the update seems to have caused some issues. Can I check that you’ve already tried a reboot using the button on top?

Does the device respond to commands typed into the CLI?
Can you also check whether Skills are all loaded by typing :skills into the CLI. This should provide a list of all Skills that Mycroft attempted to load. Any in red have thrown an error when loading.

Please see my reply below

Can I check that you’ve already tried a reboot using the button on top?
Yes, I used… I see a message “speech recognition could not understand audio” (see attached image)

Does the device respond to commands typed into the CLI?
Yes, it responds using the cli-client

Can you also check whether Skills are all loaded by typing :skills into the CLI
I run and returns a list of skills, 4 are in red

mycroft-stock.mycroftai
mycroft-youtube-audio.mcdruid
pandora-skill.ethanaward
translate-skill.jcasoft

Now, I retried, sending “play pandora” from cli-client… it does not sounds anything from Mycroft (no speech from mycroft), but it is working, and is reproducing my radio station

Regards,
Grover

Cool, mycroft-stock.mycroftai is expected - it’s been intentionally disabled. The other three aren’t in the Marketplace so they didn’t get tested against the breaking changes from 20.02 > 20.08.

I find the easiest way to see what’s causing the issue for a Skill that fails to load is to try and reload it. You can either touch a file in that Skill eg:

touch /opt/mycroft/skills/translate-skill.jcasoft/__init__.py

or in the CLI:

:deactivate translate-skill.jcasoft
:activate translate-skill.jcasoft

This will cause Mycroft to attempt to reload the Skill, and the cause of the error will get shown in your log output.

You can also find these at /var/log/mycroft/skills.log

In terms of the “speech recognition could not understand audio” error, this indicates that Mycroft isn’t detecting any speech in what it’s hearing. Can you tell if the microphone is working at all?
Does the “Mic Level” indicator in the bottom right of the CLI jump around?
If you type “set a timer”, you will then be prompted to what length timer, if you speak then, does it transcribe what you’re saying?

I tried the tips in cli-client

:activate translate-skill.jcasoft

Then, I send the order “set a timer” and it recognizes and set timer (see attached image) and I could see in the display, the counting according to timer.
However, speaking “Hey mycroft” Wake command does not work, no message displayed in the CLI. Also I tried type Hey Mycroft and then speak an order and it fails, voice is not recognized and no message.

I verified my device is connected and the wake word is Hey Mycroft

Regards,
Grover

Hi,

I did some configuration to sound

pi@mark_1:~ $ cat .asoundrc
defaults.pcm.card 0
defaults.ctl.card 0

Then I tried the mycroft-mic-test, and it was possible to record and reproduce sound.

Then, I opened CLI and retried type “set a timer” and now, it does not recognize, any order I sent can speak. Only “play pandora” can reproduce sound

I run mycrot-speak and has no sound
I run mycroft-speech-client and got this

pi@mark_1:~ $ mycroft-speech-client
2020-10-08 04:32:41.263 | ERROR | 3540 | mycroft.client.speech.main:on_error:183 | Audio service failed to launch (PermissionError(13, ‘Permission denied’)).

I do not know what to do…

I have also had problems with audio, but only with Pianobar, which I see you are trying to use too. I’m not using Mark, but raspberry pi4 with picroft.
I have complete audio other than pianobar/pandora.

When you run pianobar outside mycroft, do you get audio? Mine is distorted through the analog raspberry pi 4 card.
I am using Picroft, so I’m thinking that the audio form pandora is not at the right rate for picroft’s pulseaudio settings.
Sorry to kind of hi-jack your post.
I am totally willing to go into the pianobar skill and tweak it. pianobar uses c and libao I saw.

As for no sound and permission denied , do you have an ~/.libao file?

Mine is
default_device=pulse
I’ve had permission issues when it was
default_device=alsa