Build an open future with us.

Invest in Mycroft and become a community partner.

Wake word not working with precise


#21

Have you tried saying pair my device or typing pair my device onto the CLI?
It definitely sounds like an issue in that the device hasn’t been paired with home.mycroft.ai yet.


#22

Yes, I have done this many times before and it automatically does the pairing and I put the code into the website and all is good. Now when it tries to pair or when I type in “pair my device” I get the response:

Connection to mycroft dot a.i, failed,
pairing code could not be fetched. Check your
internet connection and try again.
When I exit and try to ping mycroft.ai I get ping results back so my computer can access mycroft.ai.
Ron


#23

Ok, it seems to work not. I just left it running and after many tries it connected. Maybe it was too busy before. Anyway that is back working now. Now back to see why precise does not work. I have an idea I am working on and will get back to you today.


#24

Seems to work “now”. A mistype.


#25

May have a reason for the problem with precise. I installed precise manually and tried to train a new wake word. I got an invalid instruction error. I posted my problem and Matthew Scholdfield was nice enough to help. It seems my xeon processor does not support AVX extensions which Matthew says tensorflow requires. I reverted to an earlier version of tensorflow and the error went away (still did not work well but I link that to problems with inconsistent versions). I do not know if the precise commands used by mycroft require tensorflow. Perhaps it is failing silently making precise go away without mycroft sw realizing. Or for some reason it works (might drop back to earlier version) but it is incompatible with hey-mycroft model. Can you find out if mycroft uses tensorflow when invoking precise? It is possible precise only uses tensorflow when training in which case it should not be a problem with mycroft use. I tried reverting to tensorflow 1.5 as I did with precise test but I got no dif results. Unfortunately I do not have a processor which supports AVX to try out mycroft. Not sure how RPI gets away with this as it does not support AVX but perhaps the RPI version works around that. I am using ubuntu on x86_64 processors.


#26

No worries, thanks for confirming @Ron777