What happened to Ezra?

When I first installed Picroft, some time ago, there were options in the MyMycroft dashboard to change the wake word, per this post:

I was able to find a place where I could change it, and selected ‘Ezra’, which worked just fine. I don’t currently have that PiCroft instance available, so I don’t know if it still responds to Ezra or not, but I do see that it is still noted as the wake word on my Dashboard. In fact, ALL of my devices show this.

But, as far as I can see, there no longer is a way to change the wake word from the dashboard. Is this capability really no longer available?

1 Like

I should clarify - there is no longer any way under ‘Defaults’ to change the wake word for any of my devices.

I used to define “Hey Jarvis” too but now it looks like they’ve made the wake word more transparent to the user:

so you can basically retrain your precise model (or even use an alternative model) which runs on the device.
So I’m left with 2 more questions:

  • when we had the chance to define the wake word in home.mycroft.ai, was it using the same “precise” model that’s now default? or was it cloud-based like google TTS?
  • where can I find the “hey jarvis” or “hey ezra” pretrained models?

you can change ww via mycroft,conf, you used to have some predefined options under mycroft home, but those have been removed and now backend always reports “hey mycroft” as selected, only way to change wake word is by editing mycroft.conf

there is no precise model for any of those wake words, those were using the older pocketsphinx engine, you need to configure the phonemes and threshold manually. Do note that pocketsphinx is much less accurate than precise

thanks @JarbasAl ! where can I find the pocketsphinx’s “Hey Jarvis” phonemes and config? it used to work decently with my setup.

here is what selene used to report back, luckily i had this saved in personal backend repo since those dont seem to be publicly listed anywhere?

 "hey_mycroft": {"phonemes": "HH EY . M AY K R AO F T",
                        "module": "ovos-ww-plugin-pocketsphinx",
                        "threshold": 1e-90},
        "hey_jarvis": {"phonemes": "HH EY . JH AA R V AH S .",
                       "module": "ovos-ww-plugin-pocketsphinx",
                       "threshold": 0.000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001},
        "christopher": {"phonemes": "K R IH S T AH F ER .",
                        "module": "ovos-ww-plugin-pocketsphinx",
                        "threshold": 1e-25},
        "hey_ezra": {"phonemes": "HH EY . EH Z R AH",
                     "module": "ovos-ww-plugin-pocketsphinx",
                     "threshold": 1e-10}

thanks! working as before with:

{
  "max_allowed_core_version": 21.2,
  "listener": {
    "wake_word": "hey jarvis"
  },
  "hotwords": {
    "hey jarvis": {
      "module": "pocketsphinx",
      "phonemes": "HH EY . JH AA R V AH S .",
      "threshold": 1e-90
    }
  }
}