Mycroft Community Forum

MycroftOS - A bare minimal (production type of) OS based on Buildroot

OK, we will get that sorted together when I have another test version for you :wink:

@j1nx I thought I give it a go and test the snapcast option (also like evaluate against my current squeezebox). For testing, I would like to setup two raspis one running server / client (RP4) and the other running the client only (RP3). I tried to figure config options myself, but failed so far. Can you provide me with the need infos to get those up and running?

So far I experienced nothing that i would call a real problem. Lots of stuff to smoothen later, for sure, but right now this is a working product for me, at least as it comes to installing, setting up and running mycroft. Did test with various Mic / Sound setting on RP3 and RP4 - no problems so far.

Will see if I can write out some pointers similar as with the spotifyd.

Haven’t used it myself yet, but do know the architecture behind it. Will get back to you soon.

As headsup, might have a intermediate test image for you soon. Still have troubles with the wifi setup wizard, but lan works fine.

Squeezelite included of course. Need you to test as I also don’t have it setup on my network.

That would be great!

Just to keep you guys updated;

Great progress! A small update from my side. Due to limitations of Squeeze (no good touch interface, running not very stable here), I have decided to give snapcast a go, so I have switched production here to snap now and quite like it. Currently use Volumio as easy access / set-up for this. So, I am out for testing in a squeeze environment and in for testing with snapcast. But I can always use spare PIs to at least test a small ad-hoc scenario.

But, coming to think about this whole issue in more depth in the last days, I come to the conclusion, that the actual problem it seems nobody has solved is the issue that we are usually facing a more-than-one user environment. This implies esp. that users will have different accounts (e.g. spotify) they ideally don’t want to mess up. So it be great if mycroft would also be personal somehow. So ideal would be to tell mycroft somehow, who is speaking to it. In consequence it would start the spotify song from the right account (this goes further than just music). I think home automation logic can help here, to get the right settings (trying to utilize Home Assitant for this).

Obviously not challenging the 1.0.0 plans with this, I would like to know your long-term thoughts about this. I have not managed to set this up here, I do not even have the right knowledge to get this running right now. Currently struggling with the startpoint of getting different spotify accounts stream into one snapserver…

Nor problem. Squeezelite is there, people that use it will know how to configure it as it is just another Squeezelite device if they want to. There is a Squeezelite skill somewhere flying around, so eventually someone will pick it up. (Otherwise I will do it myself later on in time)

Multi user mycroft environment is something that has been discussed more often and I believe is on a very long term roadmap of mycroft it self. A lot of things are involved, which start with user speech training / recognition. Eventually it will get there I think.

There are a few community ideas and implementations, such as face recognition and recently there is the password skill from @gras64 Perhaps he can also look into more users one way or the other. The challenge after that will be how to setup multiple skills and their settings on a per user basis.

Anyhow, I already had in my mind as long term thing. Starting with face recognition, hence the reason, I also pulled in OpenCV and Motion packages already. But haven’t figured it out in my mind yet.

Anyhow: Very interested to see some sort of write up from you configuring everything. Using MycroftOS all stuff is already there; mpd, snapcast-server and snapcast-client. Just need to be configured and enabled. Will eventually follow the exact same route.

Haha, I was downloadin and installing from your git release section. There is still the MycroftOS_0.1_rpi4_alpha4.img linked :smiley:

Can you update your rls there too. I can easily watch them with my github account.
And perhaps you change the href of this articel just to your download page:

THX for your work. I will report later my results with a rpi4 (4gb ram) + respeaker core v1

Ah, right, will do!

Thanks!

Okay, my config works from scratch. This is cool so far.

But mycroft(os) told me that my mycroft is outdated? What is the common way to update?

Not implemented yet and indeed, the mycroft version on that alpha7 release is 19.8 while the alpha8 will have 20.2

Not much I can do about it now.

Not sure if Mycroft is on PyPi otherwise you might be able to run a; sudo pip install / upgrade command of some kind. (never tried it)

ahh okay, good to know.

I try it with pip to upgrade mycroft but I do not understand what happened :smile:
https://hastebin.com/ukitikolow.sql

Just like I thought, there is no mycroft-core pip package. Not on PyPi and not on Piwheels.

So basically all that lines tell you that you are up to date :smiley:

Last alpha7 release can now also be donloaded from Github

2 Likes

Wow and what a nice tutorial!

I am really happy to get a release notification with your, hopefully soon, coming alpha8 for the rpi4.

1 Like

Let me know how it holds up / works for you.

Next release, hopefully somewhere next week. (Probably end of the week)

Redoing the splash and wifi wizard setup at the moment.

1 Like

Little teaser of that work;

Making use of all the building blocks available and created by the Mycroft Dev Team for consistency, making sure that MycroftOS utilizing HDMI widescreen ratio look the same as the Mark-2 and therefor familiar to everybody.

(Using the graphics of Mycroft, but other code for the wifi wizard)

The last two (or three) screens will eventually be replaced by the Mycroft GUI and the pairing skill.

1 Like

Are you crazy! Its looking awesome!

just a mention for the alpha 7 release. I am not able to reboot or shutdown the device with voice. Mycroft ask me >>Confirming: Would you like me to restart now? I say ‘yes’ and nothing happened.

Perhaps a bug of an old mycroft rls?

1 Like

It’s a bug. Or actually, it is not yet implemented. That part should be taken care of by the enclosure code, but pushed that forward as their is still an outstanding discussion about what would be the best approach.

Well, pushed forward sounds a bit to harsh as it might be seen as I am waiting for that PR which is not the case. I have still enough other tasks.

However, my aim is to use all things from mycroft and follow whatever route they take. MycroftOS is just the OS, what runs, how it works and how it looks is all up to the official Mycroft team.

Edit: By the way @suisat is your respeaker core v1 working out of the box?

1 Like

Sorry, I did not own a respeaker core v1. I own a ReSpeaker Mic Array v2.0 and this is working out of the box.