Picroft aborts speeking since 19.02 update


#21

I have the raspberry pi with the aiy hat… Today I shutdown -h now. I turned the pi off and then back on. When it booted up, for whatever reason the microphone on the aiy hat wasn’t working. So just for the sake of experimenting I asked mycroft ( using the keyboard) some things that I know would have long sentences. Mycroft read the long sentences with no issue. I tried it a few times with the same results. No issues. Next I did a sudo reboot. When mycroft came up the microphone was back and working. I tried long sentences again and the problem was back, mycroft aborted speaking sentences.
It seems that the issue my be with the microphone on the aiy. does anyone know where the aiy microphone is controlled in picroft?


#22

I tried installing the Linux version from the master branch and it the problem still exists.


#23

Pi B here with AIY Hat on 19.2.1 and .2 and same issue. I performed the gtts upgrade and it indicated that it was already up-to-date.


#24

@forslund, same here, just updated my picroft to 19.2.2 and tried to upgrade gtts, but it says it is current with version 2.0.3

Error still there for longer sentences. Though it seems that output is a bit longer than before. Strange.


#25

I’ve pushed a longshot. For mimic and mimic2 the tts thread will now sleep until the audio has played. It’s unlikely to be the solution since it wouldn’t affect gtts.

If anyone is able to test if it makes any difference run

git fetch
git checkout bugfix/aiy-cutoff

And then restart mycroft.


#26

thanks for the tip, just tried it, but I have problems with “read timed out” to api.mycroft.ai, could have been there already

on holidays from tomorrow, will check again later


#27

The read timeouts are unrelated (Ongoing backend issue). Thanks for trying!


#28

The read time outs should be resolved. I’ve updated the branch slightly so do a git pull next time you try.


#29

The Picroft updated to 19.02.3. Should that be enough to get the updated code?


#30

No change on the aiy-cutoff attempt.


#31

Thanks wiggins. Back to the drawing board I guess.