PiCroft with Respeaker 2-mic PiHat

Yeah, I’m beginning to think that too. I will contact the seeed-studio support and will update this thread. Thank you very much for your help.

1 Like

Hi everyone, here is a short update how I get the Respeaker 2-mic PiHat to run:

  • fresh install of the Picroft image
  • abort the start of the mycroft-client
  • apt update && upgrade
  • git clone https://github.com/respeaker/seeed-voicecard.git
  • cd seeed-voicecard; sudo ./install.sh; reboot
  • cd /etc/modprobe.d
  • Disable the builtin sound card: cd /etc/modprobe.d and add a file: alsa-blacklist.conf with the following line “blacklist snd_bcm2835”

When you now stop the mycroft-services (mycroft-stop)
The following commands will work:

  • arecord -f cd -Dhw:0 | aplay -Dhw:0

If your configuration don’t get save in alsamixer, you have to disable pulseaudio in the config.

Also edit the mycroft.conf to the following:
$ cat /etc/mycroft/mycroft.conf
“play_wav_cmdline”: “aplay %1”,
“play_mp3_cmdline”: “mpg123 %1”,

But I still need some advise:
When I run “mycroft-start audiotest -l” everything works and I get an audiooutput from the taken record.
But when I run the mycroft-cli-client, mycroft doesnt understand my commands all the time. How can I analyse this? Could it depends on backround noise?