Build an open future with us.

Invest in Mycroft and become a community partner.

Unable to run mycroft-core CLI since last Friday noon


#21

At the top of the skills log file there are a lot of import errors:

ImportError: No module named mycroft.dialog
Traceback (most recent call last):
  File "/home/louis/mycroft-core/mycroft/skills/main.py", line 24, in <module>

but that’s probably the old errors as the process shouldn’t be able to start at all if that was still true.

The skills in question exist but does not seem to ever be loaded. msm exits with an error (-2) which is bad. But I’m not quite certain what that means, but it seems like it gets terminated before it’s done updating. Could be that the messagebus service goes down for some reason.

The messagebus log looks like it’s being terminated by an external signal about the same time as the msm process has problems.

Looking at the mycroft-voice.log it looks like the pairing is complete since it seems to be getting valid responses.

It can take a minute or so for the skill to get loaded since the skills are checked for updates before it’s started. so you might want to start it, leave it alone for a minute or two and then trying to interact with it.

Can you provide platform and OS?


#22

I am running it on Ubuntu. I tried waiting 2 minutes but then, i can’t write anything anymore in the input as it’s lagging.


#23

can you type top in a terminal and see which process is overloading the cpu. And just to be ceertain it’s on a desktop PC right? @Louis_cormaille


#24

also I see there’s a config file: ~/.mycroft/mycroft.conf if there’s no sensitive information in there could you maybe post that as well?


#25

I am running it on a laptop MSI GS60 ghost.
There is no such file.
Only those :
drwxrwxr-x 2 louis louis 4096 Oct 6 18:27 identity
drwxrwxr-x 2 louis louis 4096 Oct 6 18:22 intent_cache
drwxrwxr-x 29 louis louis 4096 Nov 18 15:15 skills
-rw------- 1 louis louis 3243 Nov 18 16:08 wakeword_rsa
(which have not been modified since a long time apparently)


#26

@forslund Here is a video showing what is happening. Maybe it’s going to be easier for you to see what’s going on
https://drive.google.com/open?id=1iHeOeUCHjjsuOpDRyfCCpIyD_kz4kiVx


#27

From the video I can see that mycroft is still updating

... SKILLS DEBUG {type: "msm.updating" ...}

When this is done (after a minute or so) a similar message ... "msm.updated" ... should scroll by. Followed by a lot of intent registrations.

I’ll look into it more tomorrow morning.

/Åke


#28

Thank you for your help. I’ve uploaded a new video, starting this time, 5 minutes after i started running Mycroft


#29

Hi, it’s veeeery slow there. and that should not be the case for fairly modern computers.

Do you get the mycroft “listening” sound?

Have you modified the wakeword? is it mycroft or the default “hey mycroft”. Looking at the feedback it seems like the stt only registers half the sentence (the last part) and misshears “news” for “use” so no intent is triggered there.

I suggest you try “hey mycroft” pause for a couple of seconds (while the “listening” sound is playing) and then “play news”.

While you do that I’ll keep digging trying to find out what causes the slowdown.

/Åke


#30

It is very slow indeed ! :slight_smile:
I do have Mycroft listening sound but it seems to get activated even when I don t say the wake word.
I did change the wake word to “Mycroft” instead of “hey mycroft”.
I ll try to change back the wake word to its default value and do what you suggested, tonight. I ll record it.
Than you again for your time !
@forslund, uploaded the video, it still seems like Mycroft can’t find any skill


#31

Can you provide an updated mycroft-skills.log file?


#32

Updated the drive folder with the new logs !


#34

@forslund, if it can help somehow, I noticed that mycroft started lagging as soon as I see a “username for https.github.com:” appearing in the input, after I start mycroft with ./start-mycroft.sh debug. Then, when I try to write, it lags and the “username for https.github.com:” disappears from the input field.


#35

Hmm, could it be some problem when updating the skills?

One idea might be to delete all the skills

rm -rf /opt/mycroft/skills/*

and then wait for ~20 minutes for mycroft to reinstall them all.

Might be worth a shot, but I don’t know…


#36

THANK YOU !! It actually worked :o !! FINALLY !


#37

Woooo! Glad to hear! Good info about the github message helped alot!

Hopefully it keeps working for a while now :wink: