Mycroft Community Forum

Auto startup question from a noob

I installed mycroft on a respeaker core v2 board. Its running Debian, and I have the debian version of mycroft installed on it. Mycroft works, there are just a few questions I have…

How can I get Mycroft to auto start on power up. My board requires a login every time it boots, so I would somehow need to have mycroft start without requiring that login…

Also, I’m not sure if anyone is familiar with the Respeaker Core v2 board, but it can do Echo Cancellation, Noise filtering, Direction of arrival, beam forming, etc. all the write ups I see on it show how to integrate all of that with Amazon’s voice service. I don’t want to use Amazon’s voice service, I want to use Mycroft. But I have no idea how to take their instructions, and adapt it to work with mycroft. I tried doing all the steps up until the point where you actually link it to AVS, but when I do that, Mycroft no longer hears my voice, I think its setting the mic inputs to go to a different area or something weird… if anyone knows about that and could guide me that would be awesome. here is a link to the respeaker page. http://wiki.seeedstudio.com/ReSpeaker_Core_v2.0/

To answer your first question. Have a look at the “Installing Mycroft” section here (blunt self promotion :smiley: );

You need the systemd file.

To answer your second question. Keep on eye out on that blog series, as I will eventually get there… :wink:

1 Like

Great question @jjohnston7 and good on you for hacking on Mycroft :wink: Big thanks to @j1nx, his advice here is going to be way better than mine!

@jjohnston7 Just checking out the respeaker V2 board info, but it uses respeakerd based on libraries they wrote called librespeaker.

That is not the way forward as respeakerd is what precise is within Mycroft, with the exception that it is doing that stuff piped through pulseaudio.

As it has a 8 Channel ADC with 6 Microphone Array and 2 Loopbacks, you might have a look at their voice engine ec code;

I believe that is the Echo Cancellation stuff from respeakerd but than without the integrated wake-word stuff which allows you to still use precise.

Have a look here at the last few comments;

You have two loopbacks, so you should be able to use the EC_HW version. Perhaps you than do not have the timing issues.

1 Like

I followed that voice engine ec thing. I got to step 3 under ec_hw. when I run the select audio input device commands, it says running press ctrl: c to exit. but I can’t do anything until I exit. so how would I get it to run, while running mycroft too…

@jjohnston7 have you made any progress with Mycroft on the respeaker core v2?

I am not jjohnston7 but also own a Respeaker Core v2. The latest Mycroft from git-install is running fine on it and I am preparing a “guide” how to install and configure Mycroft on it. Didn’t attempt it yet but the autostart of the Mycroft services should be a easy configuration excercise as the OS is a plain Debian Stretch.

I also developed a skill that supports the LED pixel ring and the user button: https://github.com/domcross/respeaker-io-skill - this is still work in progress, but if you have the time to test it I would welcome any feedback.

Right now I am looking into the “respeakerd” service and check out it capabilities. Looking at the source code I think there is an undocumented mode where the “hotword detection” can be disabled and only the beamforming and echo/noise-canceling is used.

2 Likes

Sounds great. Do you have Mycroft running with the acoustic echo cancelling from the respeaker board?

Yes, I have a MP3-radio stream playing loud music and Mycroft still understands me while I don’t have to raise my voice level.

There is still some work to do, mainly configuration and sorting out some depencies, e.g. respeakerd must be run in pulse-mode, but it seems that pulseaudio does not start automatically and so on…

Took me some time, but here is my guide for Mycroft on Respeaker Core v2

2 Likes