Can't install or configure skills from marketplace


#1

** Picroft enclosure platform version: Stretch Lighting
** mycroft-core: 19.2.14 ( master )
Using the Google AI voice kit

I swear this worked before, but doesn’t work any more. I reinstalled Mycroft on a Pi yesterday, deleted the old device from my account, added the new device. It’s paired successfully with my account. I go into the skills marketplace, select a skill, and click “Add”. Nothing happens. The button has the graphical effect showing that I clicked it, but that’s it. Nothing is installed on the device, marketplace doesn’t show it’s installed or doing anything, and nothing shows up in the “Configure Your Skills” page. Rebooting the device doesn’t change anything. I’m almost confident I installed and configured skills through the web UI on the previous device, (which was really the same hardware, I just did a fresh install).

I can install skills manually on the device using MSM or cloning skills directly, but none of those skills show up on the web dashboard as installed or configurable. Changing voices from the web UI changes the voice on the device, so there is definitely communication between the device and the web. Any ideas? Is any of this expected behavior, or is all of this unusual?


#2

This is a known bug that is being worked on. Check the chat ~home-troubleshooting for updates (though there will likely be a post here as well).