Build an open future with us.

Invest in Mycroft and become a community partner.

Changing voice in mycroft.conf


#1

Hi,

Trying to change voice in mycroft.conf from

  "tts": {
    // Engine.  Options: "mimic", "google", "marytts", "fatts", "espeak", "spdsay", "responsive_voice"
    "module": "mimic",
    "mimic": {
      "voice": "slt"
    },

to

  "tts": {
    // Engine.  Options: "mimic", "google", "marytts", "fatts", "espeak", "spdsay", "responsive_voice"
    "module": "mimic",
    "mimic": {
      "voice": "voices/cmu_us_gka.flitevox"
    },

This doesn’t work. Could someone please help me assign voice properly?

Thanks,
Mark


#2

not sure, but i think you need to provide a full path

there are also some “baked in” voices try the following values

  • ap
  • slt
  • kal
  • awb
  • kal16
  • rms
  • awb_time

kal is probably Kevin Lenzo
ap is Alan Pope
rms is probably Richard Stallman
awb is probably Alan Black
no idea on slt, if someone knows ping me since im curious :slight_smile:

EDIT:
all info you need is here, you can also provide a url and the voice will be download


#3

Thanks so much for the quick response, JarbasAl!

I solved it with:

  "tts": {
    // Engine.  Options: "mimic", "google", "marytts", "fatts", "espeak", "spdsay", "responsive_voice"
    "module": "mimic",
    "mimic": {
      "voice": "/home/anon/mycroft-core/mimic/voices/cmu_us_gka.flitevox",
      "duration_stretch": "1.0",
      "int_f0_target_mean": "100"
    },