Mycroft Community Forum

Disabling "I'm sorry I don't understand"

Working on a fallback skill that uses a scrapper to retrieve some stuff online. The skill itself processes correctly, however in the part where the web scraping module gets called, a query timeout triggers followed by “I’m sorry I don’t understand”. Scrapped data is then returned and spoken out by Mycroft successfully.

I guess it has to do with requests module and the way queries are resolved not being part of main script’s process?

Anyways, since the fallback is still processing through to the end, if the above cannot be resolved I was thinking of simply disabling “I’m sorry I don’t understand” on a global level for this specific project, but I can’t find where it is.

1 Like

As a reference, when using the common play structure you can extend the timeout. There may be a similar method to delay the processing of the fallback skill while you retrieve your answers.
Here is some info on extending for the common play.
@gez-mycroft or @forslund may know if this can be done for other skills as well.

1 Like

I haven’t tried this at all, but it might work to disable the Unknown Fallback Skill using the mycroft.conf blacklist.

Sounds like the ability to extend the timeout is the right solution though. I imagine this would be the same as Jarbas’s changes to Common Play whereby Skills can request a timeout extension up to a configured max timeout.

2 Likes

Thank you! I will go for the extension and revert to blacklisting as a plan B.