How to configure Mycroft for Kaldi software?

Hello,

At https://github.com/MycroftAI/mycroft-core/blob/dev/mycroft/stt/init.py , I can see that Mycroft can use Kaldi STT.
After long hours, I have compiled Kaldi sources but I found no documentation that explain how to launch Kaldi server because of the following lines in mycroft.conf file:
// “kaldi”: {
// “uri”: “http://localhost:8080/client/dynamic/recognize
// }

and how to configure Kaldi withna specific language in the mycroft.conf file.

Somebody can help me ?

PS : I have Mycroft Mark 1 and my goal is to have it in French before Christmas 2017.

Hi,

I’ve not used Kaldi myself yet. Looking at the code it seems like the Kaldi interface doesn’t make use of the lang parameter.

So this means that the audio will be transmitted to Kaldi and it will use the loaded model to analyze the audio returning a string.

The ~/.mycroft/mycroft.conf should look something like

{
  "stt": {
    "module": "kaldi",
    "kaldi": {
      "uri": "http://localhost:8080/client/dynamic/recognize"
    }
  }
}

I believe the kaldi-gstreamer pre-built docker image is easier to get going with:

then replace the line loading the English sample module with the French one.

I’ll try to set this up tonight to see if I can help more.