Build an open future with us.

Invest in Mycroft and become a community partner.

Issue setting up picroft streach 18.8.0 on google aiy


#1

hey there i am trying to set up the mycroft on a google aiy kit and i keep getting this error when i get to the mic test

any ideas what i can do to get around this


#2

Hey there @Baron_ultimax, first of all a warm welcome to Mycroft and thanks for giving us a try.

An invalid sample rate error is definitely and audio input error, and the solution is usually to choose a different microphone, or ensure the correct microphone is selected. If you use alsamixer are you able to select a different input device or change any of the settings for your microphone at all?


#3

Have you installed the packages needed for the aiy kit? You will need this skill https://github.com/andlo/picroft-google-aiy-voicekit-skill and there is a script included in that repo that installs all the necessary packages for the AIY kit to function.

There are still a few issues with the install process but I have it working now minus the button.


#4

Did you try this workaround that was posted? The symptoms seem to fit the issue you’re experiencing.
https://community.mycroft.ai/t/alsa-issue-oserror-errno-9997-invalid-sample-rate