Latest Picroft image keeps losing config/breaking on RPi3b+


#1

Hello MyCroft gurus,

I’m working on a skill that I want to use in an art installation and I have PiCroft setup on a Raspi 3b+ using the raspbian-stretch_Picroft_2019-07-20.zip image.

I’m using one of those generic “3D Sound” audio adapters as audio I/O. I don’t have problems with the audio interface. mycroft-mic-test works every time.

My problem is that every time I reboot PiCroft, something breaks.
The fresh install worked after I manually edited the mycroft.config to force it to use the default audio interface for playback, but after a few reboots, I now get this in the log every time I launch the cli-client.

I get no microphone level meter until I run mic-test, but even after that, mycroft doesn’t respond to the wake word.

Log Output: 0-26 of 26
================================================================ mycroft-core 19.2.14 ===
Establishing Mycroft Messagebus connection…
Connected to Messagebus!
[971] Failed to execute script engine
Traceback (most recent call last):
File “precise/scripts/engine.py”, line 21, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “precise/network_runner.py”, line 20, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/init.py”, line 142, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/add_newdocs.py”, line 13, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/lib/init.py”, line 19, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/lib/polynomial.py”, line 20, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/linalg/init.py”, line 51, in
File “/home/pi/mycroft-precise/.venv/lib/python3.4/site-packages/PyInstaller/loader/pyimod03_importers.py”, line 631, in exec_module
File “numpy/linalg/linalg.py”, line 31, in
ImportError: cannot import name ‘lapack_lite’
15:20:21.777 - mycroft.skills.core:load_skill:122 - INFO - ATTEMPTING TO LOAD SKILL: mycroft-pairing.mycroftai with ID mycroft-pairing.mycroftai
15:20:27.145 - mycroft.skills.core:load_skill:151 - INFO - Loaded mycroft-pairing.mycroftai

I do not know why it keeps janking out like this. When I need to reboot, I do mycroft-stop, then sudo reboot now. I may have rebooted without stopping mycroft before that, I don’t know if the “ungraceful” shutdown is the reason for this behavior.

Maybe somewhat useful info: I install my experimental skill by cloning my repo to /opt/mycroft/skills - it’s a bit of a chunky repo at 80+ Mb, but that should be ok? Is this way of “installing” my skill problematic?

Also, something I noticed is that when I use the setup-wizard audio config, when I save the audio device selection I get the usage options of jq dumped on-screen before proceeding to the next step. I assume it gets an invalid argument from the setup script.

Do you have any advice on how to keep this unstable behavior from happening and if there is anything I can do to restore functionality to this image as it is now? I will appreciate your input a lot, I can’t get a stable platform running in order to continue working on my skill.


#2

Hi Stefan,

Cool to hear you are using this in an art installation.

The error log you’ve posted seems to be a problem in loading Precise, the wake word engine. Did you try to change anything with Precise?

Can you post the contents of the mycroft.conf file the you changed just to rule anything out there. Also is there anything in ~/setup-choices? If so can you post that too.

In terms of the Skill install, cloning into the directory should work, however it’s generally best to install with the following command to make sure requirements are met etc:

mycroft-msm install https://github.com/author/skill-repo

I’m guessing the 80+ Mb includes a bunch of audio files that the Skill plays?