Mark II language change

I tried to follow FAQ - Mycroft Mark II to change the language of my Mycroft II

As mycroft-config is not yet supported in Dinkum, I manually added "lang": "es-ES" in mycroft.conf file

When I restart, Mark II gets stuck in Download settings

Any clues on what is going on? I can help with debugging!

I did the same for German adding "lang": "de-de" to the config. After that I had the same situation as you - Mycroft got stuck during booting. After looking into logfiles I found that several localization resources for skills etc. were missing (in my case for “de-de”).

As a quick&dirty solution I copied all missing files from the “en-us” folders into the “de-de” folders. This will get you over the stuck “Download settings” but some skills/intent will not react to prompt in your language as the intent is available in English only.

You can look into Skills-Logfiles by sudo journalctl -f -u dinkum-skills
There was also a file from /opt/mycroft-dinkum/shared/mycroft/res/text/de-de missing: noise_words.list - I simply created a empty file with that name.

You may also want to change the configuration for STT and TTS to your language. For STT i have installed VOSK (using vosk_stt_plug plugin), for TTS I use Mimic3 with a german voice.

1 Like

Thank you for the answer @Dominik !

I was able to boot Mark II adding the required files. I also setup Vosk, but I was stuck in configuring Mimic3. I opened an issue, but maybe I am missing something?

I had some initial Mimic3 issues, too. Maybe it helps to manually install the resources for your language first by:

pip install mycroft-plugin-tts-mimic3[en,es]
mimic3-download es_ES/carlfm_low