Build an open future with us.

Invest in Mycroft and become a community partner.

Mycroft doesn't respond to audio / getting passive-aggressivemed


#1

Hi all,

Recently reinstalled Mycroft on ubuntu and now it won’t respond to my voice.
Here’s a quick recap of events:

Sunday, Jan 6th early morning: experimenting with adding NLTK chatbandot for fallback responses. Decide on the “rude” bot and I’m very entertained by snippy responses in place of the usual boring “…don’t know but learning every day” response.

Afternoon: return from mass w/ wife and cotinue to modify chatbot. Sometime during my third Slovakian mimosa (OJ & vodka), decide to change Mycroft’s name to “Mister Beals.” Fetch the phonetics from http://www.speech.cs.cmu.edu and edit mycroft.conf and https://home.mycroft.ai/#/setting/advanced. Mycroft now responds to “Mister Beals” and doles out insults. SUCCESS!

Monday morning: decide to change Mr. Beals’ voice to something more formal and British sounding to up the snark factor of the insults. At some point, I notice that Mr. Beals is not playing the wav wake sound when I call him. He still responds and functions, but without playing the wav. I check the config and everything seems to be proper. I take a gram of phenitbut and 200 mg of l-theanine as I ponder the problem.

Monday night: By this time I’ve consuned another 4+ grams phenibut and three Carthusian Sazeras. Another unrelated install is causing problems. After rebooting and attempting to resolve this new disaster (fsk -f and such), I take the drastic measure of reinstalling ubuntu and mycroft. Now mycroft no longer responds to voice at all despite the clean install. Also, the option to change the wake word at /setting/advanced is grayed and set to ‘hey mycroft’ and doesn’t allow for edit.

audio.log below. I’ve installed from git+https://github.com/JarbasAl/py_mplayer w/ pip and pip3 w/ no effect and still receive that error. Not even sure if that even pertains to this problem.

Please advise.

Thanks,
Mark

p.s. is it possible that mycroft is sabotaging my system as a rebellion against these modifications?

00:56:59.749 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:56:59.771 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:56:59.787 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:56:59.801 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:56:59.816 - mycroft.identity:_load:44 - DEBUG - Loading identity
00:56:59.818 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:57:00.097 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6 HTTP/1.1" 200 366
00:57:00.118 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:57:00.132 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:57:00.146 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:57:00.146 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:57:00.607 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 200 3053
00:57:00.611 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:57:00.909 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 200 4
00:57:00.935 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:57:00.953 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:57:00.964 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:57:01.244 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/subscription HTTP/1.1" 200 114
  Carnegie Mellon University, Copyright (c) 1999-2011, all rights reserved
  mimic developers, Copyright (c) 2016, all rights reserved
  version: mimic-1.2.0.2 ()
00:57:01.271 - __main__:main:38 - INFO - Starting Audio Services
00:57:01.274 - mycroft.messagebus.client.ws:on_open:62 - INFO - Connected
00:57:01.276 - mycroft.audio.audioservice:get_services:58 - INFO - Loading services from /home/anon/mycroft-core/mycroft/audio/services/
00:57:01.277 - mycroft.audio.audioservice:load_services:102 - INFO - Loading chromecast
00:57:09.830 - mycroft.audio.audioservice:load_services:102 - INFO - Loading mopidy
00:57:09.833 - mycroft.audio.audioservice:load_services:102 - INFO - Loading mplayer
00:57:09.846 - mplayer__init__:<module>:20 - ERROR - install py_mplayer with pip install git+https://github.com/JarbasAl/py_mplayer
00:57:09.847 - mycroft.audio.audioservice:load_services:108 - ERROR - Failed to import module mplayer
ModuleNotFoundError("No module named 'py_mplayer'",)
00:57:09.847 - mycroft.audio.audioservice:load_services:102 - INFO - Loading simple
00:57:09.849 - mycroft.audio.audioservice:load_services:102 - INFO - Loading vlc
00:57:09.903 - mycroft.audio.audioservice:load_services_callback:171 - INFO - Finding default backend...
00:57:09.904 - mycroft.audio.audioservice:load_services_callback:175 - INFO - Found local
00:57:38.973 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:57:39.265 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/subscription HTTP/1.1" 200 114
  Carnegie Mellon University, Copyright (c) 1999-2011, all rights reserved
  mimic developers, Copyright (c) 2016, all rights reserved
  version: mimic-1.2.0.2 ()
00:57:39.289 - mycroft.audio.speech:mute_and_speak:119 - INFO - Speak: My name is Wolfram|Alpha.
[('4', 0.204), ('4', 0.251), ('0', 0.37), ('3', 0.443), ('0', 0.611), ('4', 0.685), ('0', 0.793), ('3', 0.876), ('2', 0.958), ('2', 0.981), ('3', 1.076), ('5', 1.174), ('2', 1.246), ('0', 1.345), ('4', 1.449), ('4', 1.484), ('0', 1.691), ('2', 1.751), ('0', 1.894), ('3', 1.988), ('5', 2.074), ('0', 2.108), ('4', 2.324)]
00:58:06.933 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:58:06.934 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:07.163 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 304 0
00:58:07.169 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:07.414 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 304 0
00:58:07.422 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:58:07.423 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:58:07.424 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:58:07.425 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:07.653 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 304 0
00:58:07.659 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:07.894 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 304 0
00:58:07.901 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:58:07.902 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:58:07.904 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded
00:58:07.905 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:08.136 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 304 0
00:58:08.140 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443
00:58:08.394 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 304 0
00:58:08.403 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping
00:58:08.404 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded
00:58:29.979 - mycroft.audio.speech:mute_and_speak:119 - INFO - Speak: full name, Caitlyn Jenner.
[('4', 0.148), ('5', 0.266), ('2', 0.293), ('3', 0.421), ('3', 0.52), ('0', 0.721), ('4', 0.89), ('4', 1.001), ('3', 1.082), ('0', 1.223), ('3', 1.295), ('3', 1.351), ('0', 1.431), ('3', 1.536), ('3', 1.646), ('0', 1.748), ('3', 1.787), ('2', 1.895), ('4', 2.136)]
00:58:30.184 - mycroft.audio.speech:mute_and_speak:119 - INFO - Speak: date of birth, Friday, October 28, 1949 (age: 69 years).
[('4', 0.205), ('3', 0.243), ('0', 0.421), ('3', 0.507), ('0', 0.561), ('5', 0.608), ('4', 0.693), ('2', 0.825), ('3', 0.924), ('4', 1.025), ('5', 1.128), ('2', 1.199), ('0', 1.304), ('3', 1.369), ('0', 1.508), ('4', 1.653), ('0', 1.807), ('3', 1.85), ('3', 1.932), ('2', 2.048), ('4', 2.113), ('2', 2.17), ('3', 2.288), ('2', 2.34), ('0', 2.408), ('3', 2.495), ('3', 2.577), ('0', 2.712), ('0', 2.874), ('3', 2.969), ('3', 3.07), ('4', 3.13), ('3', 3.206), ('0', 3.376), ('3', 3.46), ('3', 3.546), ('0', 3.633), ('3', 3.719), ('5', 3.829), ('6', 3.967), ('2', 3.984), ('3', 4.096), ('0', 4.185), ('3', 4.253), ('0', 4.448), ('3', 4.53), ('0', 4.763), ('3', 4.918), ('4', 5.044), ('4', 0.072), ('3', 0.2), ('0', 0.299), ('3', 0.358), ('3', 0.492), ('3', 0.537), ('0', 0.625), ('3', 0.704), ('0', 0.841), ('3', 0.936), ('0', 1.061), ('0', 1.199), ('2', 1.247), ('3', 1.388), ('4', 1.479)]
00:58:30.740 - mycroft.audio.speech:mute_and_speak:119 - INFO - Speak: place of birth, Mount Kisco, New York
[('4', 0.144), ('4', 0.219), ('3', 0.263), ('0', 0.392), ('3', 0.523), ('0', 0.608), ('5', 0.658), ('4', 0.725), ('2', 0.836), ('3', 0.932), ('4', 1.023), ('4', 1.069), ('1', 1.278), ('3', 1.365), ('3', 1.457), ('3', 1.556), ('0', 1.616), ('3', 1.739), ('3', 1.776), ('2', 1.994), ('4', 2.122), ('3', 2.187), ('2', 2.348), ('0', 2.489), ('6', 2.743), ('2', 2.763), ('3', 2.826), ('4', 2.96)]
00:58:56.311 - mycroft.messagebus.client.ws:on_error:74 - WARNING - Could not send message because connection has closed
00:58:56.312 - mycroft.messagebus.client.ws:on_error:83 - ERROR - Exception closing websocket: Exception("Uncaught 'error' event.",)
00:58:56.312 - mycroft.messagebus.client.ws:on_error:85 - WARNING - WS Client will reconnect in 5 seconds.
00:58:57.811 - mycroft.audio.audioservice:shutdown:444 - INFO - shutting down local
00:58:57.817 - simple__init__:stop:135 - INFO - SimpleAudioServiceStop
00:58:57.817 - mycroft.audio.audioservice:shutdown:444 - INFO - shutting down vlc
00:58:57.818 - vlc__init__:stop:69 - INFO - VLCService Stop
00:58:57.819 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.play'
00:58:57.819 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.queue'
00:58:57.819 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.pause'
00:58:57.820 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.resume'
00:58:57.820 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.stop'
00:58:57.821 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.next'
00:58:57.821 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.prev'
00:58:57.822 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.audio.service.track_info'
00:58:57.822 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'recognizer_loop:audio_output_start'
00:58:57.823 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'recognizer_loop:record_begin'
00:58:57.823 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'recognizer_loop:audio_output_end'
00:58:57.824 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'recognizer_loop:record_end'
00:58:57.824 - mycroft.messagebus.client.ws:remove:163 - DEBUG - Removing found 'mycroft.stop'
00:58:57.824 - mycroft.messagebus.client.ws:remove:169 - WARNING - Failed to remove event mycroft.stop: <bound method AudioService._stop of <mycroft.audio.audioservice.AudioService object at 0x7f6db0320438>>
00:58:57.825 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/usr/lib/python3.6/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
00:58:57.826 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/usr/lib/python3.6/runpy.py", line 85, in _run_code
    exec(code, run_globals)
00:58:57.826 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/home/anon/mycroft-core/mycroft/audio/__main__.py", line 49, in <module>
    main()
00:58:57.826 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/home/anon/mycroft-core/mycroft/audio/__main__.py", line 46, in main
    audio.shutdown()
00:58:57.827 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/home/anon/mycroft-core/mycroft/audio/audioservice.py", line 464, in shutdown
    self.bus.remove('mycroft.stop', self._stop)
00:58:57.827 - mycroft.messagebus.client.ws:remove:171 - WARNING - File "/home/anon/mycroft-core/mycroft/messagebus/client/ws.py", line 170, in remove
    for line in traceback.format_stack():
00:58:57.828 - mycroft.messagebus.client.ws:remove:174 - DEBUG - Removing found 'mycroft.stop'
00:58:57.828 - mycroft.messagebus.client.ws:remove:177 - WARNING - Existing events: defaultdict(<class 'list'>, {'new_listener': [], 'configuration.updated': [<function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>], 'configuration.patch': [<function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>], 'mycroft.stop': [<function handle_stop at 0x7f6db50d3ae8>], 'mycroft.audio.speech.stop': [<function handle_stop at 0x7f6db50d3ae8>], 'speak': [<function handle_speak at 0x7f6db5ccfd08>], 'mycroft.mic.listen': [<function _start_listener at 0x7f6db5d30bf8>], 'message': [<function create_echo_function.<locals>.echo at 0x7f6db2397950>], 'open': [], 'SimpleAudioServicePlay': [<bound method SimpleAudioService._play of <simple__init__.SimpleAudioService object at 0x7f6da07d8eb8>>], 'mycroft.audio.service.play': [], 'mycroft.audio.service.queue': [], 'mycroft.audio.service.pause': [], 'mycroft.audio.service.resume': [], 'mycroft.audio.service.stop': [], 'mycroft.audio.service.next': [], 'mycroft.audio.service.prev': [], 'mycroft.audio.service.track_info': [], 'recognizer_loop:audio_output_start': [], 'recognizer_loop:record_begin': [], 'recognizer_loop:audio_output_end': [], 'recognizer_loop:record_end': [], 'connected': [], 'register_vocab': [], 'register_intent': [], 'mycroft.skills.loaded': [], 'enclosure.mouth.text': [], 'enclosure.mouth.reset': [], 'mycroft.internet.connected': [], 'padatious:register_intent': [], 'mycroft.scheduler.schedule_event': [], 'padatious:register_entity': [], 'mycroft-reminder.mycroftai:reminder': [], 'mycroft-timer.mycroftai:ShowTimer': [], 'mycroft.scheduler.remove_event': [], 'detach_intent': [], 'enclosure.eyes.reset': [], 'mycroft.skills.initialized': [], 'recognizer_loop:utterance': [], 'intent_failure': [], 'mycroft.skill.handler.start': [], 'enclosure.mouth.think': [], 'mycroft.skill.handler.complete': [], 'enclosure.mouth.viseme': [], 'mycroft-date-time.mycroftai:TimeSkillupdate_display': [], 'mycroft-configuration.mycroftai:ConfigurationSkillupdate_remote': [], 'error': []})
00:58:57.829 - mycroft.messagebus.client.ws:remove:179 - WARNING -    new_listener
00:58:57.829 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.829 - mycroft.messagebus.client.ws:remove:179 - WARNING -    configuration.updated
00:58:57.830 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>, <function Configuration.updated at 0x7f6db6921f28>]
00:58:57.830 - mycroft.messagebus.client.ws:remove:179 - WARNING -    configuration.patch
00:58:57.830 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>, <function Configuration.patch at 0x7f6db692b048>]
00:58:57.830 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.stop
00:58:57.831 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function handle_stop at 0x7f6db50d3ae8>]
00:58:57.831 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.speech.stop
00:58:57.831 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function handle_stop at 0x7f6db50d3ae8>]
00:58:57.832 - mycroft.messagebus.client.ws:remove:179 - WARNING -    speak
00:58:57.832 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function handle_speak at 0x7f6db5ccfd08>]
00:58:57.832 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.mic.listen
00:58:57.832 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function _start_listener at 0x7f6db5d30bf8>]
00:58:57.833 - mycroft.messagebus.client.ws:remove:179 - WARNING -    message
00:58:57.833 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<function create_echo_function.<locals>.echo at 0x7f6db2397950>]
00:58:57.833 - mycroft.messagebus.client.ws:remove:179 - WARNING -    open
00:58:57.834 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.834 - mycroft.messagebus.client.ws:remove:179 - WARNING -    SimpleAudioServicePlay
00:58:57.834 - mycroft.messagebus.client.ws:remove:180 - WARNING -        [<bound method SimpleAudioService._play of <simple__init__.SimpleAudioService object at 0x7f6da07d8eb8>>]
00:58:57.834 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.play
00:58:57.835 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.835 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.queue
00:58:57.835 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.835 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.pause
00:58:57.836 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.836 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.resume
00:58:57.836 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.837 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.stop
00:58:57.837 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.837 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.next
00:58:57.837 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.838 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.prev
00:58:57.838 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.838 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.audio.service.track_info
00:58:57.839 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.839 - mycroft.messagebus.client.ws:remove:179 - WARNING -    recognizer_loop:audio_output_start
00:58:57.839 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.839 - mycroft.messagebus.client.ws:remove:179 - WARNING -    recognizer_loop:record_begin
00:58:57.840 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.840 - mycroft.messagebus.client.ws:remove:179 - WARNING -    recognizer_loop:audio_output_end
00:58:57.840 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.840 - mycroft.messagebus.client.ws:remove:179 - WARNING -    recognizer_loop:record_end
00:58:57.841 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.841 - mycroft.messagebus.client.ws:remove:179 - WARNING -    connected
00:58:57.841 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.842 - mycroft.messagebus.client.ws:remove:179 - WARNING -    register_vocab
00:58:57.842 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.842 - mycroft.messagebus.client.ws:remove:179 - WARNING -    register_intent
00:58:57.843 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.843 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.skills.loaded
00:58:57.843 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.843 - mycroft.messagebus.client.ws:remove:179 - WARNING -    enclosure.mouth.text
00:58:57.844 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.844 - mycroft.messagebus.client.ws:remove:179 - WARNING -    enclosure.mouth.reset
00:58:57.844 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.845 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.internet.connected
00:58:57.845 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.845 - mycroft.messagebus.client.ws:remove:179 - WARNING -    padatious:register_intent
00:58:57.845 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.846 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.scheduler.schedule_event
00:58:57.846 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.846 - mycroft.messagebus.client.ws:remove:179 - WARNING -    padatious:register_entity
00:58:57.846 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.847 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft-reminder.mycroftai:reminder
00:58:57.847 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.847 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft-timer.mycroftai:ShowTimer
00:58:57.848 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.848 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.scheduler.remove_event
00:58:57.848 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.848 - mycroft.messagebus.client.ws:remove:179 - WARNING -    detach_intent
00:58:57.849 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.849 - mycroft.messagebus.client.ws:remove:179 - WARNING -    enclosure.eyes.reset
00:58:57.849 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.849 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.skills.initialized
00:58:57.850 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.850 - mycroft.messagebus.client.ws:remove:179 - WARNING -    recognizer_loop:utterance
00:58:57.850 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.851 - mycroft.messagebus.client.ws:remove:179 - WARNING -    intent_failure
00:58:57.851 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.851 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.skill.handler.start
00:58:57.851 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.852 - mycroft.messagebus.client.ws:remove:179 - WARNING -    enclosure.mouth.think
00:58:57.852 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.852 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft.skill.handler.complete
00:58:57.853 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.853 - mycroft.messagebus.client.ws:remove:179 - WARNING -    enclosure.mouth.viseme
00:58:57.853 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.853 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft-date-time.mycroftai:TimeSkillupdate_display
00:58:57.854 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.854 - mycroft.messagebus.client.ws:remove:179 - WARNING -    mycroft-configuration.mycroftai:ConfigurationSkillupdate_remote
00:58:57.854 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.855 - mycroft.messagebus.client.ws:remove:179 - WARNING -    error
00:58:57.855 - mycroft.messagebus.client.ws:remove:180 - WARNING -        []
00:58:57.855 - mycroft.messagebus.client.ws:remove:182 - DEBUG - Removing found 'mycroft.stop'
00:58:57.855 - mycroft.messagebus.client.ws:remove:185 - WARNING - ----- End dump -----


#2

py_mplayer error can be ignored and should be unrelated to this, i’ll let someone else help you on debugging however :stuck_out_tongue: @KathyReid is probably the person for the job, worst case she will know who to ping

quick note, try to use pastebin or equivalent, it hurts to see a wall of text with logs and isn’t very easy to parse for debugging, plaintext is king for logs

EDIT: did you come from erowid? i feel like i’m reading a trip report :smiley: hehe, just kidding


#3

Hi there @SwampMidget, thanks for your detailed logs. I edited your post to show them in code view.

I can’t see anything initially wrong from the audio.log. Are there any errors in your voice.log?

Changing the playback voice is a function of the TTS - the Text to Speech Subsystem. Changing this should not change whether a “ding” sound is heard when the Wake Word is detected. What is more likely here is that the Audio Service is using a different audio player for speech playback (.wav) compared to the “ding” sound (.mp3) and that the “ding sound” player is not working / is not loaded. This is why we need to look at the voice.log.

Can you please send a screenshot of your Mycroft Wake Word settings in home.mycroft.ai?


#4

Hi Kathy,

Thanks for the response and sorry for the wall of text code dump.

I’m still having problems: mycroft no longer listens to my voice (much like my wife), and I’m not getting the ackonowledge sound. Another anomaly that may be relevant: the mic is picking up my voice as the sound meter bars are showing, but the units next to the bars are in the thousands. I seem to recall them being lower before the reinstall. Could this have something to do with the threshold setting I found on https://mycroft.ai/documentation/home-mycroft-ai-pairing/#telling-mycroft-to-pick-up-the-new-settings ? Included below is my voice.log that you mentioned. I found no errors but do find the but do find the line about a “slave process” a little disturbing. Here is the screenshot of my advanced setting of home.mycroft.ai

I thank you for your help on this problem. I hope my description of the problem makes sense as I’m still on a rather high dose of phenibut HCL. I’ll be cycling to a caffeine & l-theanine combo starting tomorrow, so I’ll be much more succinct and focused in my future posts.

Thanks,
Mark_

`00:56:59.656 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded 00:56:59.658 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded 00:56:59.659 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping 00:56:59.660 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded 00:56:59.661 - mycroft.identity:_load:44 - DEBUG - Loading identity 00:56:59.664 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:56:59.958 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6 HTTP/1.1" 200 366 00:56:59.961 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded 00:56:59.963 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping 00:56:59.964 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded 00:56:59.965 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:57:00.338 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 200 3053 00:57:00.341 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:57:00.765 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 200 4 00:57:00.769 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping 00:57:00.770 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded ALSA lib pcm_dsnoop.c:618:(snd_pcm_dsnoop_open) unable to open slave ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave 00:57:00.790 - mycroft.client.speech.listener:create_wake_word_recognizer:243 - INFO - creating wake word engine 00:57:00.791 - mycroft.client.speech.hotword_factory:load_module:273 - INFO - Loading "hey mycroft" wake word via pocketsphinx 00:57:00.808 - mycroft.client.speech.listener:create_wakeup_recognizer:263 - INFO - creating stand up word engine 00:57:00.809 - mycroft.client.speech.hotword_factory:load_module:273 - INFO - Loading "wake up" wake word via pocketsphinx 00:57:00.825 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:57:01.046 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6 HTTP/1.1" 304 0 00:57:01.054 - mycroft.messagebus.client.ws:on_open:62 - INFO - Connected 00:57:03.025 - mycroft.client.speech.mic:listen:487 - DEBUG - Waiting for wake word... 00:58:06.933 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/mycroft-core/mycroft/configuration/mycroft.conf loaded 00:58:06.934 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:58:07.163 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/setting HTTP/1.1" 304 0 00:58:07.169 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai:443 00:58:07.415 - urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 "GET /v1/device/b253d494-80ed-4ec2-91d4-68e5fdd85ad6/location HTTP/1.1" 304 0 00:58:07.421 - mycroft.configuration.config:load_local:114 - DEBUG - Configuration '/etc/mycroft/mycroft.conf' not defined, skipping 00:58:07.421 - mycroft.configuration.config:load_local:109 - DEBUG - Configuration /home/anon/.mycroft/mycroft.conf loaded


#5

Hi there @SwampMidget,

Firstly, were you able to provide your voice.log so we can take a look at that?

Mycroft not listening to your voice

This indicates that the microphone is not capturing the speech input properly. You’ve indicated that the meter bars are showing, which could mean that the “gain” on the microphone is either too high or too low. A good way to check this is with the alsamixer utility, which allows you to adjust the gain on a microphone.

“Ding” acknowledge sound

There are three possibilities here. One is that Audio Service which plays .mp3 files is not working. Your audio.log would have had errors though if this were the case. Another possibility is that the acknowledge sound has been switched off in a configuration, but this is done by editing a file and is unlikely to be mistakingly changed. The third possibility is that Mycroft is not “dinging” because the output device - the speaker - is not properly selected.

The threshold setting is used for the Wake Word only; it is not used for microphone input or speaker output.

This block of output possibly indicates the wrong device is selected.

If you run the command aplay -l what is the output?


#6

Thanks JarbasAI,

OK py_mplayer error eliminated as possibility. These log files have are a never ending mystery. I feel like I’m trying to decipher Sanskrit or something.

“did you come from erowid?” LOL I wanted to send you a DM and tell you that I’m just having some fun w/ the whole phenibut nonsense. But it seems I can’t find the private msg option on this forum despite searching for 15+ min. Plus, I can’t seem to get the code block tag to work on here. [code] [\code], right? Welp, didn’t work for some reason. Perhaps that phenibut stuff really is affecting me and I can no longer do basic tech stuff. That would explain this forum gore as well as my prob w/ getting mycroft to listen.

peace,
Mark_


#7

OK I’ll try messing with those and report back.


Wrong mycroft device or wrong hardware device?


**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0