Mycroft Community Forum

Mycroft muting audio after wakeword detected?

17:13:30.825 | INFO | 4024 | main:handle_wakeword:59 | Wakeword Detected: hey mycroft
17:13:30.829 | INFO | 4024 | main:handle_record_begin:37 | Begin Recording…
17:13:30.888 | INFO | 4018 | VolumeSkill | Volume before mute: 100
17:13:30.889 | INFO | 4018 | VolumeSkill | 100

can someone help me reset his volume skill?

Every time I say ‘hey mycroft’ he mutes the audio before the ‘wakeword detected sound’ plays, then unmutes it.

This started happening after i set an alarm via mycroft.

had to uninstall/reinstall mycroft.

this is a pretty bad bug. Can someone help me find a solution?

The problem is back. I have contacted support… hoping someone can help me with this.

If you find a solution, could you let us know? I believe it has something to do with one of the skills muting the mic when audio plays, or when Pulseaudio auto mutes the mic when playing audio. I’ve experienced it before and haven’t been able to find a way around it.

You guys might be onto something, because when pulse ducking is enabled indeed the alarm skill always get’s triggered when the “hey mycroft” is found.

 18:31:01.078 | INFO     |   261 | mycroft.client.speech.__main__:handle_wakeword:59 | Wakeword Detected: hey mycroft
 18:31:01.718 | INFO     |   261 | mycroft.client.speech.__main__:handle_record_begin:37 | Begin Recording...
 18:31:01.772 | INFO     |   259 | AlarmSkill | on started...
 18:31:04.546 | INFO     |   261 | mycroft.client.speech.__main__:handle_record_end:43 | End Recording...
 18:31:04.696 | INFO     |   259 | AlarmSkill | on ended...

Perhaps there is a bug in that logic. I assume that the alarm should trigger during the short (or longer) break of the mute. There might be a bug in that logic. But I believe the one that could see, explain or investigate is @forslund

The alarm skill does some pretty wacky things to trigger the wake word silently it might be a clash between the alarm skill logic and the muting logic. I’ll give it a whirl tomorrow morning to see if I can reproduce (sounds like it should be easy) and potentially fix.

In the meantime maybe you can turn off the volume ducking using Mycroft home->skills->volume-control and unselect “Duck while listening”.

1 Like

Thanks everyone for your help. Indeed, turning ducking off fixes the issue.

Just had a look at the Alarm Skill and the reason those logs appear is because the Skill tracks whether the mic is activated and toggles an is_listening property. Interestingly it no longer uses this, the code that relied on it got removed so I’ll clean this up and clean up the logs further :slight_smile:

Hi @evon, I’ve been trying to reproduce this issue with no luck so far. Can you tell me anything of your platform. Is it a linux desktop, picroft or Mark-1?

Are you using any custom settings like wakeword or similar?

Seems like my original hunch was wrong since as @gez-mycroft informs us the alarm skill don’t do those wacky things anymore.

Hi @forslund I am on a Linux Desktop, Ubuntu 18.04. No custom settings are enabled atm. I am not having the issue anymore after I have turned “ducking” off so your hunch seemed to work :sunglasses:

2 Likes

@evon - Can you clarify the symptoms? The way I read your post the behavior is:

  1. Ducking enabled.
  2. “Hey, Mycroft”
  3. Output volume muted.
  4. Beep plays ( silently because volume is muted ).
  5. Mycroft goes into record_begin.

When ducking is disabled, the behavior is:

  1. Ducking enabled.
  2. “Hey, Mycroft”
  3. Beep plays ( silently because volume is muted ).
  4. Mycroft goes into record_begin.

Correct?

Hi @J_Montgomery_Mycroft yes that’s about right but also the alarmskill gets activated somewhere in the mix for some reason.

Just to clarify, the logging reported above was that the Alarm Skill was keeping track of whether the mic was active or not, this has now been removed. If the Alarm was doing anything other than that, then that would be a separate issue we’d need to look at.

hi @gez-mycroft I sent the logs to support 2 days ago if you want to check them out. I can’t specifically remember exactly what alarmskill was doing, but the info is in the logs.

Yeah cool I had a look and that was all I could see, so have fixed that. If you notice anything else please let us know :slight_smile:

thanks so much @gez-mycroft!! :sunglasses:

1 Like

Glad we could help. Thanks for reporting the issue!

1 Like