Mycroft on raspberry pi gives me this error and stops working

When I start Mycroft on raspberry pi it gives me this error and Mycroft stops working.
This happens every time I turn it on.

loop = RecognizerLoop()
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.8.1-py2.7.egg/mycroft/client/speech/”, line 184, in init
self.mycroft_recognizer = self.create_mycroft_recognizer(rate, lang)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.8.1-py2.7.egg/mycroft/client/speech/”, line 194, in create_mycroft_recognizer
return LocalRecognizer(wake_word, phonemes, threshold, rate, lang)
File “/usr/local/lib/python2.7/site-packages/mycroft_core-0.8.1-py2.7.egg/mycroft/client/speech/”, line 40, in init
self.decoder = Decoder(self.create_config(dict_name))
File “/usr/local/lib/python2.7/site-packages/pocketsphinx/”, line 271, in init
this = _pocketsphinx.new_Decoder(*args)
RuntimeError: new_Decoder returned -1


1 Like

Were you able to fix the issue because i am also having the same problem

Hey there.
I’m getting nearly the same error when trying to use a german wake word:

2017-06-18 16:33:28,426 - - INFO - Connected
ERROR: “pocketsphinx.c”, line 233: Cannot redirect log output
Traceback (most recent call last):
File “/home/thorsten/mycroft-core/mycroft/client/speech/”, line 221, in
File “/home/thorsten/mycroft-core/mycroft/client/speech/”, line 213, in main
File “/home/thorsten/mycroft-core/mycroft/client/speech/”, line 251, in run
File “/home/thorsten/mycroft-core/mycroft/client/speech/”, line 214, in start_async
self, self.microphone)
File “/home/thorsten/mycroft-core/mycroft/client/speech/”, line 72, in init
self.decoder = Decoder(self.create_decoder_config(model_lang_dir))
File “/home/thorsten/.virtualenvs/mycroft/local/lib/python2.7/site-packages/pocketsphinx/”, line 271, in init
this = _pocketsphinx.new_Decoder(*args)
RuntimeError: new_Decoder returned -1

Is an existing instance already running? How are you starting mycroft? Does the service and skill pieces load and work as expected (ie, no major errors in those logs)?

I got this error after change “PHONEMES”.
and solved correcting phnemes according to this site.
I think that wrong phonemes occur this error.

Were you able to solve it? If yes then how. Thanks

this maybe an issue with messing with the wakeword. If mycroft doesn’t have the correct phonemes then the wakeword recognizer goes out of whack. if you use the site above you should be able to get the correct phonemes.