Mycroft Community Forum

Mycroft Skills Confusion

So I just got Mycroft working after a bit of trouble. So of course I tested Mycroft by asking a few questions.

The first question I asked was ‘what is your network address’ because that skill had a check mark beside it when I went to the skill page in my Mycroft account.
Then I asked Mycroft to “make me laugh” and it told a “joke” but that skill didn’t have a check, neither did Weather, or Sing but they worked.

So now I am confused, what skills are installed? Why the check marks that when hovered over say “Skill Installed”?

Type the following command in the mycroft-cli-client;

:skills

Thanks,

How long does it take for installed skills to appear in https://account.mycroft.ai/skills?

A veeerrryyyy llooooong time.

There are some issues with the web-based market. Better to use the command line or voice command.

@j1nx
I used the command line to install the Home Assistant skill but it requires some config to be done.
So I need it to show up on the web page to complete the config :slight_smile:

I’ll just have to wait…

Ah right! That is not at the market but here;

https://account.mycroft.ai/skills

yah,

I re-added the Home Assistant skill last night once I figured out the issue I was having was with the voice?!?

It’s been almost 12 hours and the Home Assistant skill isn’t showing up the https://account.mycroft.ai/skills portal

Strange, mine is gone as well.

@gez-mycroft Sorry to ping you, not sure if we need you or not but…

Apparently the Home Assistant skill is not available anymore at the skills section page. Can you have a look?

@j1nx Glad it’s not just me this time :slight_smile:

Hmmm, mine was there, I removed it and re-added and it took >10 minutes to show up which is not normal, but it did eventually sync.

There’s some extra improvements to Skill settings handling about to hit the dev branch so perhaps we can see if that resolves things first.

Did some testing today as well.

On my laptop all good.
On my MycroftOS RPI running python 3.8 one of the requirements could not be installed because there are no wheels for it on both the pi repo as well the pypi repo.

Perhaps that is the issue. Will dig deeper.

The new Skill settings handling is performing really well. Much more reliable and responsive.

It’s in the dev branch of mycroft-core if you are comfortable switching to give it a try. Otherwise it will be coming in the next stable release which shouldn’t be far off.

1 Like