Build an open future with us.

Invest in Mycroft and become a community partner.

Mycroft.skills.settings:_poll_skill_settings:401 - ERROR - Failed to fetch skill settings:


#1

Hello,

I’m getting ERROR after fresh installation and pairing. I’m getting no response after giving voice command.
Attached, please find the screen shots.
Please help me to solve this issue.

Regards,
smearumi


#2

Hello, thanks for using Mycroft. Currently, we are experiencing a spike in traffic which is definitely a good thing, but it causes a heavy load on our servers. Every other service should work fine, but our skills service may intermittently fail to fetch skill settings. You can still use your skills like normal but syncing settings from the web may be an issue. We are currently working on resolving this issue and will update the community accordingly.


#3

The microphone-not-responding issue I think is separate to the skill-settings-not-being-fetched issue.

Are you able to stop and start the mycroft-skills service by doing:

sudo service mycroft-skills stop && sudo service mycroft-skills start

and let us know how you go?

Kind regards,
Kathy


#4

@KathyReid

Thank you for your reply. I can’t stop or start the mycroft-skills service. Please check below for the terminal output. I’ve also attached a screen shot of mycroft startup log output for your better understanding.

[rumi@localhost mycroft-core]$ sudo service mycroft-skills stop && sudo service mycroft-skills start
Redirecting to /bin/systemctl stop mycroft-skills.service
Failed to stop mycroft-skills.service: Unit mycroft-skills.service not loaded.
[rumi@localhost mycroft-core]$ sudo service mycroft-skills stop
Redirecting to /bin/systemctl stop mycroft-skills.service
Failed to stop mycroft-skills.service: Unit mycroft-skills.service not loaded.
[rumi@localhost mycroft-core]$ sudo service mycroft-skills start
Redirecting to /bin/systemctl start mycroft-skills.service
Failed to start mycroft-skills.service: Unit mycroft-skills.service not found.
[rumi@localhost mycroft-core]$

Regards,
Rumi


#5

@Mn0491

Thank you for the reply. I hope the server issue will be resolved very soon.

Regards,
Rumi