Neon AI for Mark II for free

Thanks for the NEON!

After using it for 2 or 3 days now it has crashed.

Booting gives me a Kernel panic “not syncing: UPS unable to mount root fs on unknown block(0-”

Thanks @thegoldbug for sharing this, I do want to know if anyone has issues with their Neon. I’m sharing my email response here for the benefit of anyone else looking for troubleshooting:

Thank you for sharing your issue, that is very helpful to us in improving our Neon OS. I have some follow-up questions and troubleshooting suggestions.

What exactly did you do to change the activation word? That isn’t actually an enabled feature, though we’re working on it. If there’s a misleading setting available we’d like to fix that.

Thank you for the screenshot. Basic troubleshooting, which I expect you’ve already done, would be to make sure only the Neon boot drive is connected and is plugged into USB port 0 (the blue one on the left - Tips - NeonAI® Documentation).

If it’s plugged in to the correct port, with no other USBs plugged in, then it appears your USB has become corrupted. Are you technical enough to re-image the drive with these instructions? I know it’s a bit of work you were probably looking to avoid by ordering the USB. If you have the time, it would be valuable to us to know if this fixes your issue. You will need to download our OS from here or the link here on our webpage, and download a free imaging program if you don’t have one already. We suggest Raspberry Pi Imager or Balena Etcher

Installation Instructions:
Plug your blank USB drive into your computer (use the one that’s not working)
Open Imager (we suggest Raspberry Pi Imager or Balena Etcher)
Under ‘Operating System’, select ‘Use Custom’
Locate and select the Neon image you downloaded
Under ‘Storage’, select your USB drive
Click ‘Write’ and wait for the image to be written and verified
Remove the USB drive and plug it into your Mark II
Plug power into your Mark II
After starting up, you will be guided through connecting to WiFi

I’m also available to walk you through this process on a tech support video call, if that would be helpful.

I see your USB order from a few days ago. Thank you for trying out Neon and providing this valuable feedback. Please keep me posted on how things go so I can make sure you end up with a working copy of Neon again.

Best regards,

Okay, i’ve done the reflash and I’m back up and running.
As for what I changed (but that didn’t seem to break NEON) was under the
Menu\settings\developer\advanced configuration\hot words

I checked the Enable box for Hey mycroft.

The reason I did this was because about every 3 to 5 minutes while watching youtube videos on 3D printing NEON would wake up and try to tell me something about Caffine or that it didn’t understand but then displayed text that was quite good at matching what the youtube influencer said.

PS. I see this screen upon the first bootup after flashing. Anything to worry about?

1 Like

FYI, @NeonClary, I had almost the same problem (I did not check word for word on the screen) as thegoldbug. Here is what I did:

  1. Put the (free mailed to me) drive in the blue USB slot.
  2. Booted up and set up the wifi, etc.
  3. After a while shut it down to play again with Dinkum.
  4. Made an image file on my Ubuntu system using sudo dd if=/dev/sdc of=~/neonImage.img
  5. Unfortunately left the drive in the USB slot while I rebooted sometime later. Ubuntu apparently tried to boot the USB stick and failed miserably .
  6. Stuck the stick back in the MkII and got the fail message.

It is certainly possible that 5. (and maybe 4 but I don’t think so) corrupted the USB stick. In any case, I’ll follow your instructions to re-image the stick.

1 Like

Re-imaging the drive worked.

1 Like

We got ours (very nice looking USB key Neon chose btw) a couple weeks back, thank you! It boots up okay at first, but almost every time we try to do an update it fails (I think we may have succeeded once or twice, but then when we do a second update it fails). Then it will have a kernal panic when it tries to boot.

We then flashed a new image from the current image available from the Neon web site, but each time we have tried it we get the same problem. The first time it boots fine, but fails the first or second time we try to update.

I should add that I’d purchased a preloaded Neon USB key previously and that one hasn’t had the issue. I’ve been able to update that one at will (now running the current Beta release).

@NeonClary Is it some kind of hardware issue with the USB key?

1 Like

Finally, finally, finally! Somehow this time we seem to have finally succeeded (after something like 5 failures). We flashed NeonOS 22.10.3 and then updated to 23.3.15 on the release update track, then switching to the beta track we were able to update to 23.3.17a2. This makes me think maybe it was something with beta 23.3.16ax? updates that were failing. It failed so many times I was on the verge of writing off that USB key altogether. @NeonClary

1 Like

@NeonClary Neon on MkII: It has been running for a few days, and I said “Hey Neon, restart now please”. No response at all. In fact after that it would not respond to anything. I power cycled it, and now I am back to the dreaded “Kernel Panic, Not syncing”

As a software developer myself, I know that is relatively little info. Before I re-image, would sending you an image of the current USB key be useful? I can copy it off on another system.

@NeonClary, I’m not going to wait…I did make a copy of the crashed system, and I will reflash (again) Neon. Is there a better place for discussion of problems? I created an account on element, and got essentially nowhere once I had logged in.

@burns I’m sorry about the delay! I was out sick the last two days. Did you get all the way into our Element rooms? Daniel normally monitors those and Mattermost quite closely.

To respond to your original query, we haven’t hit a number of hardware issues that would cause us to do a deep dive, so immediate re-imaging is perfect. If that fails, I’ll replace it.

@Collab Thank you for the information, that sounds quite frustrating! I know it I’m glad you had success at last. If you have any further issues with that USB key please let me know so I can replace it.

Also, @burns and @Collab are you two interested in trying out Neon on SSD drives? I have a few of those I can send out to folks who would give them a good test drive.

Oops. I was half asleep last night and replied to the notification mail about this rather than here. Anyway, no worries…I hope you are feeling betting now, @NeonClary.

Yes, I did find the Element room, and “talked” to Daniel. In fact all very promising…I have a couple times corrupted the Flash drive, but not since I updated to the latest beta. I now have Neon talking to Home Assistant, which is talking to my Hubitat. So far working reasonably.

I’m happy to help with an alternate type of drive if it is useful. I’m not sure if I’m going to be a HEAVY user, but I do have a tendency to do things that show up problems :slight_smile: I’d still like to get my Hubitat skill ported to Neon, but I wanted to port it from PiCroft to Dinkum first. Unfortunately, that does not seem possible since I can’t ssh to Dinkum (public key never shows up as a parameter). Maybe I can use the Home Assistant skill as a basis.

Continued thanks for all your support!

1 Like