Mycroft Community Forum

New RPI 4 build Respeake mic array and smartpi touch 2

Hi all, im starting a new build and would like to know if anyone else has had experience with the rpi4 and more specifically the OS to use between ubuntu 64, buster lite 32 and pre built picroft image.

Also I would like to use the smartpi touch 2 to display data from the skills. From what I can tell from the docs its like a web based implementation of the mycroft gui. Has any one done this and has anyone made the gui interactive e.g touchscreen usable?

You should checkout the Mycroft OS project and can download the GUI image from https://www.j1nx.nl/downloads/

On that link you can download the latest “released” version. If you would like to download older versions, or perhaps the current bleeding edge version (alpa9) you could also have a look at my shared folder on STACk;

https://j1nx.stackstorage.com/s/6vIDwIIIlvYH3Vw

In case of the alpha9 version. Keep a mind on the upload date as I once in a while push a newer version to people that are helping me out one way or the other. I overwrite the old one, so…

Thanks for the heads up guys!

ive just gone through the forum section devoted to mycroftOS, very impressed. I should of picked up on this sooner because I have a selection of pi’s mics and speakers that i could of helped test with.

im guilty of tinkering before reading documentation or forums.

I will look to install that tonight. I would like to help if i can, so what version of mycroftOS would you like me to test using the stack i described?

If you have a RPI4, that best is to grab the latest alpha9 version from that shared folder.

Shouldn’t matter if you use the respeaker or usb microphone. Most USB devices are picked up properly. I now have two on my list that need some attention through udev, reloading drivers/sound architecture when detected, but nothing more at the moment. If you have some usb devices, interested to know if they work out of the box or not.

If you have a touch enabled screen, you could help me out at the next step of including back in the settings menu within the “skill-mycroftos-gui” code.

Yes I do, and of course I would like to help you out. I’ve never used the mycroftOS but if you detail exactly the use cases you’d like me to test and maybe a quick explanation of how, i will detail my findings and post it in the mycroftOS forum section.

1 Like

Just to let you know I used this set up last night

Official Raspberry Pi 7 Touchscreen Display
Rpi 4b 4gb
Usb mic
Mini speaker using the jack

Alpha9 did not get to boot screen just stayed blank

Alpha8 went through the loading splash screen but then got stuck just after

I will try alpha7 tonight with the same stack and then try again with my rpi3b.

Last night I did some testing with the latest alpha9 in combination with the Google AIY v1 and was also suprised that at the first boot indeed for some reason the screen stayed black.

SSH-ed into the box and gave it a quick reboot and all was good again. Not sure what it was and was under the impression that perhaps a little “bit” got stuck just for me but now you report the exact same, so will have another look.

My advise, don’t go down in version numbers. Perhaps it is better to do the same as me and just give it a little reboot to see if it comes up. At my dmesg I saw some atomic timing issues related to the HDMI driver, so perhaps the current kernel version wasn’t really perfectly timed. Will check the rpi kernel github repo and if needed bump the kernel and associated drivers to see if it works.

EDIT: Oh crap, I just realised the last alpha9 I build and pushed, was not a clean build after the last kernel and firmware bump :man_facepalming:

Will bump again, just to be sure and create a clean build. Downside; that will take up to almost 24 hours. Will report back, when the new image is pushed.

(BTW: Google AIY v1 voice HAT, just works with MycroftOS. All it currently needs is the “dtoverlay=googlevoicehat-soundcard” added to config.txt Hope to have it added to the auto detect logic just like the respeaker hats soon)

1 Like

Thanks for your reply. on my lunch I booted up alpha8 and after a restart from an ssh it started fine. I connected my Respeaker but I connected it via the GPIO connectors and the mic didn’t seem to work. Also it told me that mycroft version is out of date and to pull the latest version do you suggest that i do that?

just a thought does it recognize and setup the speakers on first setup or does it recognize it on each boot?

At the time of alpha8 the ReSpeaker i2c HAT drivers where not ready for kernel 5.4 - 64bit (they still aren’t, but sort of working), so if you run that version your mic will not work on either first or concurrent boot.

At alpha9 it scans the i2c bus and dynamically loads the right overlay at every boot. (2-mic hat not yet working, the others do / should)

About the version message; I have not yet worked on the update logic so not much you can do there. I will blacklist the “mycroft-update” skill till I worked on it in the future releases to get rid of the annoying message.

Right I’ve tested and tested again i can’t get alpha 9 to work with my screen. It does flicker at the very beginning and I can see power is on in the screen but no matter how many times I reboot It doesn’t want to start. But does work alpha 8 though. I started to nose around the files but it seems to be a very stripped down distro with no easy way of updating stuff myself.

Ok, hang in there a bit. A clean compile is running which will still take a good few hours to finish. I believe that one might get you going.

And yeah, it is a veey minimall embedded os specifically for it’s purpose.

Thats great, looking forward to it. I’ll keep checking the shared folder and try again at some point tonight.

I would like to create some skills but never have done, is it possible to develop a skill locally on the OS or will it need to be done on a separate machine running mycroft?

Sorry for all the questions.

Depends. There are no C compilers on the OS, so as long as it just pure Python and/or pulling in pip packages that do not require C compilation from source files, you should be fine.

And if not, just let me know. Alreaay included VOIP support, NODE-RED support, spotify, Airplay, etc.

Just code and as soon as you run into some sort of dependency error just reach out to me.

Keep tou posted about the build💪🏻

Just had a thought while I’m waiting for the build. I was wondering whether the display can go portrait as well as landscape. The skills im thinking of developing lend it self the displaying information in list form. I’m sure it would work just fine in portrait though.

Mycroft GUI can do portrait / landscape just fine, as a skill developer you can choose how you want to display your list when the screen is in portrait or landscape using the same ui for example you could do a single column list for a vertical style display and two column display for horizontal style display if you want to make use of more screen estate. Example screenshot of list of cards in vertical and horizontal responsive design can be seen here: https://github.com/MycroftAI/mycroft-core/pull/2698

1 Like

Indeed like @AIIX said, the mycroft-gui QT5 application can do both portrait / landscape, no problem in that regard.

If it comes to the underlying OS support, currently that is a little bit different. Last time I checked, whic to be fair is already some months ago, the opensource mesa VC3 video driver did not yet support rotation. Need to double check if that is still the case but if it is, that would mean that currently the boot splash (the logo with filling up bar) can not yet be rotated. As soon as QT5 takes over, the rotation would be fine.

On a side note: A new version is compiled but as I am still at my daytime job have not yet been able to test it myself yet. By all means if you would like to give it a go, here it is;
https://j1nx.stackstorage.com/s/BOhbo546nAbKkAgc

I 7zipped the image down to a quarter of it’s size because from here I have a crappy internet connection, so pushing a 2GB image would have taken ages.

If you test it before I do, please let me know the outcome.

No joy in terms of of touch screen display working just stays blank. I’m going to try a vanilla distribution and see if its my screen or the OS. I’m out now but will let you know later.

Right, that is strange. Just quickly ran the last version and see no problem. Would love to get to the bottom of this together. Considering that you do have screen output on older versions it must be some driver issue with the latest rpi kernel I think.

Please reach out to me over DM or some kind. Would like to add proper support for your screen.

Hi j1nx, that sounds good to me. I should have some time to night. I will ssh onto my pi and DM you any relevant log to do with that screen.

1 Like