No voice w/o building mimic (SOLVED)


#1

I’ve got Mycroft running on my Antergos (Arch) PC following the instructions on https://mycroft.ai/documentation/linux/ and it’s all fine if I build mimic. But I get no audio if I don’t build mimic.

Am I mistaken? I thought it would still have a voice unless I’m not connected to the internet? I’ve done this twice on 2 completely fresh linux installs.

I use the plasmoid to see the written responses and to switch Mycroft on and off while testing.


#2

Mimic (1) works offline. Without it, you wouldn’t hear a voice. That’s correct. Mimic2 requires a connection to the internet unless you run a server for that locally.


#3

I’m always connected to the internet. How do I know which version of mimic I have?
I assume it’s 2 because during install it says I won’t have voice if I’m NOT connected to the net so to build mimic for that case.


#4

The local built one is more robotic and has an odd cadence. mimic2 has a more natural sound.


#5

Thanks, well then I have the more robotic version 1 that I built during install, but why doesn’t it work if I don’t build it locally?


#6

That’s what it’s designed to be–a local TTS engine.


#7

Yes I know that but the installation message states that a local mimic is only needed if I’m going to be offline which I never am so why does it not work if I choose to NOT build mimic locally?

Maybe I don’t understand the naming, is mimic ONLY a local build program and the online service is called something else?


#8

Online tool is mimic2, but you have to have an account to use that.


#9

I have an account, if I didn’t I wouldn’t have been able to register my computer as a Mycroft Device.
So back to my original question, why do I have to build mimic locally when it’s supposed to work (according to the installation notes & as long as I am online) in order to have a voice?


#10

Unless you’ve specifically configured another tts engine, mimic will be the tts engine. Without either a) mimic installed, or b) another tts configured and working, you won’t hear anything.


#11

Ok thanks you’re saying the same thing as I came to believe but that means the installation text is either wrong or incomplete, but anyway that’s my question solved :slight_smile:


#12

Hi @robgriff444

Sorry for the confusion, this page is on my list of documentation to update (along with lots of others). If you have any specific ideas on how it could be improved we would love any and all feedback. You can submit this either using the documentation ratings at the bottom of every page in the documentation, or directly on the github repo.

Glad to hear you got mimic up and running locally though :slight_smile:


#13

@gez-mycroft Thanks, here’s the message:

"Mycroft uses its Mimic technology to speak to you. Mimic can run both
locally and from a server. The local Mimic is more robotic, but always
available regardless of network connectivity. It will act as a fallback
if unable to contact the Mimic server.

However, building the local Mimic is time consuming – it can take hours
on slower machines. This can be skipped, but Mycroft will be unable to
talk if you lose network connectivity. Would you like to build Mimic
locally? "

Having had no Mycroft experience before installing this I assumed that ‘from a server’ meant in the cloud (ie already there). I see now what was meant but it is only clear when you know!