Pandora Loading Error


#1

When I tell Mycroft to “Play Pandora”, I get the following message:
Pandora failed to load. Please verify your email and password at home.mycroft.ai

Skill: Pandora at https://github.com/MycroftAI/pianobar-skill
Platform/OS: I’m using Mycroft for Linux, on Ubuntu 18.04
I have…

  • Double checked my email and password on both https://home.mycroft.ai and pandora.
  • Downloaded pianobar
  • Restarted Mycroft

Here is the support ticket: http://termbin.com/lvbs
What logs, if any, would you me to provide?


#2

I was actually just working with someone yesterday with a similar issue. See if this works.

  1. Clear out your home skill settings for Pandora. Hit save up on top after you clear them out.

  2. Reboot your device.

  3. Put back in your Pandora password and hit save.

  4. Reboot your device.

  5. Hey Mycroft, Play Pandora.

Let us know if that works. I think they uncovered a bug yesterday making it necessary for those reboots. Also, just a question, how many devices do you have associated with your account? If you hover over the “I” info sign in home.mycroft.ai skill settings it will tell you the “owner device”. If that isn’t the one you are working with, reboot that device too during step #4

Hope that helps…


#3

Having this exact same issue with a fresh PiCroft install. The proposed solution does not work.

Log sez:
FileNotFoundError: [Errno 2] No such file or directory: ‘pianobar’


#4

For feed back only:
I ran into the same problem as B3U, with the same configuration (Mycroft, Master branch) + (Ubuntu Linux 18.04).
Nate, your recommendation worked to resolve my problem.


#5

This solution did not fix my problem. I am still getting the Pandora error.

The logs say there is “no process found” for pianobar process 331.


#6

pianobar is one of the blacklisted skills. I’m not sure why, but after letting that load, and rebooting, pandora works great!!