Picroft is getting stuck on Bluetooth dependency


#1

My Picroft on a RPi 2 (I know) in a Google AIY Voicekit usually works pretty well, if a little slow. I’m used to it.

But for the past few days, the light comes on when called, but no sound, no voice, and doesn’t respond to commands. Tried SSHing in, but it turns out it’s not online.

I just plugged it into a monitor and found it’s getting stuck on this line during boot-up:

    [DEPEND] Dependency failed for Configure Bluetooth Modems connected by UART

Now, I suspect that the problem is that the RPi2 doesn’t have bluetooth and that’s why it’s getting stuck here.

But this didn’t used to be a problem. Was there an update that makes this a requirement? Can I fix this without buying a Pi3?


#2

I can’t think of any changes that would have caused this, we certainly aren’t adding any bluetooth modules in.

This is not my area of expertise, but it sounds like you can “disable the system service that initialises the modem so it doesn’t use the UART”
sudo systemctl disable hciuart
https://www.raspberrypi.org/documentation/configuration/uart.md

Maybe worth a shot?