Build an open future with us.

Invest in Mycroft and become a community partner.

Problem setting Google as Speech To Text Engine in Setting tab of mycroft


#1

Hi, I have selected google tab in as my tts and added api key as provided, But when i run voice service it is giving me following error:-
could not request speech recognition recognition request failed: forbidden
I have done changes to file located at mycroft-core-\mycroft\stt__init__.py where i have changed
like this-
class GoogleSTT(TokenSTT):
def init(self):
super(GoogleSTT, self).init()

def execute(self, audio, language=None):
self.lang = language or self.lang
return self.recognizer.recognize_google(audio, “My Api Key”, self.lang)
please help me . any step-by-step guide or code can be helpful


#2

I have the same problem, I have:

“stt”: {
“module”: “google”,
“google” : {
“credential”: {
“token”: “{google token}”
}
}
}

Token is set in GoogleSTT

I start mycroft, say something and I get the same error: could not request speech recognition recognition request failed: forbidden


#3

Hello!

sorry to relive the subject, but I have the same problem

“stt”:{“module”:“google”, “google”:{“lang”: “es-ES”, “credential”: {“token”:“xxx”}}},


#4

I am not 100% sure as i am only using the „free“ Google-TTS (without credentials), but I think you have to use „google_cloud“ instead of „google“ in your case.


#5

I’ve been looking at the code and you have both options, at the end I’ve put the other one back.

You’re using google cloud with no credentials? Or how?