Mycroft Community Forum

Quiet Max Volume tor VLC backend

When playing music, the dynamic range for any kind of playback via VLC ranges from inaudible (at 3) to quiet (at 10). Both system and music playback volume adjust properly when called by “set volume,” but the system playback is much, much louder. Playback using the default sound backend (local) plays at an appropriate volume for the current setting. This on on current Picroft.

Is there a separate max volume for vlc or something that I am missing?

i guess that the stream gets corked (test: pactl list sink-inputs while streaming vlc) . Mentioned at the end of this thread

Comment out load-module module-stream-restore in /etc/pulse/default.pa
And you should add "listener": { "mute_during_output": false, ...
to the listener in mycroft.conf (either sys or user, whichever carries the entry).

While this (the muting/unmuting/volume situation) is running pefectly well with “pulse_duck” : true, i would’t know if this is still the case if no ducking is active :wink:
Though i also wouldn’t know why anyone should run Mycroft without “pulse_duck”:true (given the user pushed everything to pulse)

Thanks for the reply. I am a bit confused by the distinction between pulse_duck in mycroft.conf and the duck flag in the vlc audio conf. Should they both be enabled?

that’s just to ensure vlc’s ducking if pulse_duck is true. I bet big bucks that it’s about the START_CORKED (the filter that gets applied on the stream) situation

That did it! Thanks again for your help.