Skill web page not loading


#1

Hi there – for some reason my skill webpage is not loading for the last few days it just perpetually says loading skills

and in the Cli it keeps complains about port 443 timing out

20190406_101223

would anyone know the reason why and how to solve the issue


#2

Hi,

there’s an ongoing issue with the skill settings service on the backend.

We’re currently trying to isolate the exact cause and remidy the issue.


#3

thank you for the response - hopefully the issue is resolved soon


#4

Hello,
The issue should be fixed right now, let us now if you still have problems to access to skills page.


#5

yes it seams to be fixed now - thank you kindly


#6

Had the same problem. I even had no device at all paired, but she responded my questions and skills worked normally, skill page was unavailable but with the KDE-widget I could still install skills.

Had probably to do with the Arch repo built, that constructs “binaries“ to start from everywhere within the local sytem, added icon and now I have been able to start the AI with the Application menu.

I naturally paired my device afterwards to get access to skill marketplace, too.


#7

@Miranda are you facing the issue with the skills page right now? Or you meant during the outage we had during the weekend?


#8

@matheus-mycroft: yes, it was about a week ago where I had running both versions, the ./start-mycroft debug one and the one with the “binary”. Probably both versions worked, but most of the time it got hung with the “connecting to the messagebus”, where websocket couldn’t connect, I had a huge discussion on the support page around this. But now both work clearly and without any “sudo” or “–allow-root” before the commands.


#9

I had that issue too. But it’s fixed now.

It seems like documentation page has been compromised by some kind cookie hijacking. It redirects me somewhere else (Probably spam ads)


#10

Hi @nur_mhd, we did face a zero-day exploit for a short time yesterday that caused users to be redirected.

If you’re interested in more details you can see our tracking of this incident.

The cause was identified and resolved, however if you ever experience this behaviour again please contact us immediately.


#11

I’m still facing this issue (started around the same time OP posted this thread)-

The weird thing is that in Network tab in devtools, I see that https://api.mycroft.ai/v1/user/USERID/skill is returning a full response.

The only error in the console is this-

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://api.segment.io/v1/t. (Reason: CORS request did not succeed).[Learn More]
The resource at “https://api.segment.io/v1/t” was blocked because content blocking is enabled.[Learn More]

I tried logging out/back in and on both Firefox and Chromium, no luck.


#12

Hi shaan7, thanks for letting us know.

I’ve flagged it with our backend team to look into and will let you know what we find.


#13

Can you try a full refresh (Ctrl+R) and see if you still get that. The api.segment.io sounds fishy. We don’t use anything like that. I also wonder if something has snuck onto your system that is injecting code. Can you disable browser plugins and give it a shot?