Mycroft Community Forum

[SOLVED] Openhab-Skill: Cannot get item-list

Hi everyone! Thanks for contributing this code!

Unfortunately I ran into an issue with the openhab-skill.
These messages are shown:

| ERROR    | 18354 | skill-openhab | Some issues with the command execution!

Sorry cannot get the items list. 

After I could not find the skill in the marketplace, I set it up via github, following the instruction given there.

I tried to configure my OH IP and ports in my local config file (/home/…/.mycroft…) and this works with the initial startup and I can control my items using mycroft.

But after restarting mycroft these settings are overwritten with “127.0.0.1” and “8080”.

I also edited the configuration-files in /opt/mycroft/skills/openhab-skill (settings.json and settingsmetadat.yaml), but these values get overwritten to.

Than I tried the configuration-editor as in this description:
https://community.mycroft.ai/t/solved-openhab-skill-not-working-after-upgrade/7285/10

The "mycroft-config edit user"-command show correct values, but still the skill’s config files in opt don’t.

I tried different scenarios (eg with / without local config file…), but no success.

I also saw this post

https://community.mycroft.ai/t/openhab-skill-enhancement-to-use-skill-settings-fails/7383/2

but I am nut sure if I could follow the thought. @FloatingBoater - could you explain more detailed how the init.py should look?

Any hints are welcome!
Thanks!

Hi t_ho, if you’re using the master branch of that Skill there should also be a settings block at https://home.mycroft.ai/skills

The Skill checks for the Skill settings first, and if not found checks for the settings in mycroft.conf. Have you tried this method already?

1 Like

Thank you very much, gez-mycroft!

I wasn’t aware of this configuration method, as I am used to configure things from the command line (with expected fiddling : )

But
-> logging in (my account) -> navigating to skills -> open hab -> configuring IP and port
makes these changes persistent.

Cheers,
t_ho

1 Like