Mycroft Community Forum

TuneIn Internet Radio Streaming Skill - testing and feedback

Glad the skill helped test out the CPF translations :slight_smile:

1 Like

I’m finding your vocab uses “Tune in” as the key phrase to listen for. However when I get back STT I’m seeing “TuneIn” as one word which misses the intent. The image attached shows it missing for “tunein” which I spoke and handling “tune in” which I typed.
tune%20in%20error

Thanks for the bug report. I updated intent handling so it should work with either “tunein” or “tune in” now depending on how the audio is interpreted.

1 Like

Updated and things seem to be working!

1 Like

Tested the skill here as well. Works perfectly !

Tested on 19.8.2 and works flawlessly with CPS. Yes because of the huge amount of streams on TuneIn it doesn always finds the right station and yes, sometimes the station it comes up with is nowhere close to what I meant, but I believe that has more to do with again the amount of stations on TuneIn. Haven’t tried out the new yaml shortcut stuff yet, will do and report back.

Other than that, please submit this skill to the market so others can find it and easily install it. It’s worth it.

Well done. Thanks for this skill.

@johnbart To add to my feedback earlier, please have a look at this;

This Skill does not stop a active playback before starting it’s playback.

Other than that. Still a great skill ! Amazingly fast as well.

Similar to my post for your IHeartRadio skill, I can only get this skill to find my local station by speaking both the station’s call letters and frequency, either piece of information on its own leads to no results.

Also, using the “stop” command while TuneIn is playing, crashes the command line client:

Removing event mycroft-playback-control.mycroftai:PlayQueryTimeout
Removing event mycroft-playback-control.mycroftai:PlayQueryTimeout
Removing event mycroft-playback-control.mycroftai:PlayQueryTimeout
 22:30:00.503 | INFO     |   779 | Playback Control Skill | Playing with: mycroft-skill-tunein.john~~~~
 22:30:00.996 | INFO     |   779 | Playback Control Skill | Audio service status: {}
~~ed with url: /Users/AuthenticateByName (Caused by NewConnectionError('<urllib3.connection.HTTPConne~~
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
        version 1.25.10; written and copyright by Michael Hipp and others
        free software (LGPL) without any warranty but with best wishes

Directory: http://wamu-1.streamguys.com/
Playing MPEG stream 1 of 1: wamu-1 ...
ICY-NAME: WAMU
ICY-URL: https://wamu.org

MPEG 1.0 L III cbr48 44100 mono

ICY-META: StreamTitle='';
 22:32:55.610 | INFO     |   779 | QuestionsAnswersSkill | Searching for dismiss
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
Removing event fallback-query.mycroftai:QuestionQueryTimeout
 22:32:56.447 | INFO     |   779 | QuestionsAnswersSkill | Timeout occured check responses

mpg123: death by SIGTERM

Hey, thanks for this skill! I have the same Problem like Didgeridrew, when I use the stop command the cli crashes… how to fix that?

I just installed the TuneIn skill and tried to use it by asking it to “Play Christmas Music”
It responds saying it found a station and will start streaming it and then nothing happens.
At this point Mycroft seems to enter a semi-hung state. I can say “Hey Mycroft” and I can see in the Mycroft CLI that it is recognized but there is no chime nor anything further.

This is the only thing I can find in the logs
Audio.log

2019-12-11 17:37:36.373 | INFO | 900 | mycroft.audio.speech:mute_and_speak:120 | Speak: Playing streaming station WQXR Chritmas

2019-12-11 17:37:36.379 | DEBUG | 900 | mycroft.tts.mimic2_tts:get_tts:256 | Generating Mimic2 TSS for: Playing streaming station WQXR Christmas

2019-12-11 17:37:38.074 | DEBUG | 900 | urllib3.connectionpool | https://mimic-api.mycroft.ai:443 “GET /synthesize?text=Playing%20streaming%20station%20WQXR%20Christmas&visimes=True HTTP/1.1” 200 188396

17:37:38.074 - urllib3.connectionpool - DEBUG - https://mimic-api.mycroft.ai:443 “GET /synthesize?text=Playing%20streaming%20station%20WQXR%20Christmas&visimes=True HTTP/1.1” 200 188396

Works fine here;

INFO     |   238 | mycroft.skills.settings:save_settings:108 | Skill settings successfully saved to /opt/mycroft/skills/mycroft-skill-tunein.johnbartkiw/settings.json
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
        version 1.25.13; written and copyright by Michael Hipp and others
        free software (LGPL) without any warranty but with best wishes

Directory: http://stream.wqxr.org/
Playing MPEG stream 1 of 1: qxr-special?source=TuneIn ...
ICY-NAME: WQXR: New York's Classical Music Station - Holiday MP3 vm8645
ICY-URL: http://www.wqxr.org/

MPEG 1.0 L III cbr128 44100 j-s

ICY-META: StreamTitle='Unknown Artist - Little Drummer Boy';StreamUrl='http://www.wqxr.org';
  ^--- NEWEST ---^

Thanks for the tip !

Looks like you have an issue with mpg123 of some kind. How about other stations?

Same thing happens with other stations.

I’ll have to look at mpg123. I assumed it was part of the Mycroft image

Just for checking, can you post the full content of both

/etc/mycroft/mycroft.conf
~/.mycroft/mycroft.conf

Sure,

/etc/mycroft/mycroft.conf

{
“play_wav_cmdline”: “paplay %1”,
“play_mp3_cmdline”: “mpg123 %1”,
“enclosure”: {
“platform”: “picroft”
},
“tts”: {
“mimic”: {
“path”: “/home/pi/mycroft-core/mimic/bin/mimic”
}
},
“ipc_path”: “/ramdisk/mycroft/ipc/”
}

~/.mycroft/mycroft.conf

{
“max_allowed_core_version”: 19.8
}

I just realized that I have the Latest News skill which streams a MP3 file from the CBC website. Since this is working I assume that there isn’t a problem with mpg123.

Can you play streams from TuneIn outside of mycroft? With the app on your phone perhaps, using wifi on the same network.

Perhaps it is some sort of access restriction…

@j1nx
Good thought, I’m sure I’m not blocking TuneIn, but perhaps it got tagged by mistake by my ISP.

@j1nx
I was finally able to test this out and I am able to listen to TuneIn on my laptop using the same network as my Pi.

I get a similar behavior when I try to use Meowcroft (https://github.com/HotcakesSanderson/meowcroft-skill)

I tried another station (Boom FM). This is the entry in the audio.log

04:10:09.555 - urllib3.connectionpool - DEBUG - https://mimic-api.mycroft.ai:443 “GET /synthesize?text=Now%20playing%20boom%20101.9%20from%20tune%20in&visimes=True HTTP/1.1” 200 176417

It looks like, the stream just never get’s started?!?

To be honest. Really no clue what monkey business is going on here. Kind of out of ideas at the moment…

@j1nx
No worries, I’ve dug around in the logs in /var/log/mycroft and that’s pretty much the only entry I can find except for the one showing me asking to play the station.

Is there any difference between asking for something to be installed, using msm install , or mycroft-msm install ?

Nope, it’s all the Mycroft Skill Manager (MSM) under the hood.

msm is generally installed within the Mycroft virtual environment, so to make it easier you can use the mycroft-msm helper command which is callable without activating the venv. When you ask Mycroft to install something, it also calls msm to perform the installation.