Mycroft Community Forum

Unable to install mycroft on Ubuntu 14.04 due to pip errors

Hi there,

I’m trying to setup Mycroft on Ubuntu 14.04 on a Jetson TK1 board. I followed the instructions to clone git repo and run bash dev_setup.sh.

I encountered some problems and fixed some, now stuck at this step

  pip install -r requirements.txt 

in the dev_setup.sh. It keeps failing at different lines of the requirements.txt with the following

  Could not find any downloads that satisfy the requirement [whichever library/line it was]

So sometimes fail at the 1st line, or 6th or 7th or 12th etc, as if the server/network is unstable.

The furthest I could get is line 16 and it gave me a different error, shown below:

Downloading/unpacking pillow==7.1.2 (from -r requirements.txt (line 16))
  Real name of requirement pillow is pillow
  Downloading Pillow-7.1.2.tar.gz (38.9MB): 38.9MB downloaded
  Running setup.py (path:/tmp/pip_build_ubuntu/pillow/setup.py) egg_info for package pillow
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/tmp/pip_build_ubuntu/pillow/setup.py", line 305
        yield from self.features
                 ^
    SyntaxError: invalid syntax
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/tmp/pip_build_ubuntu/pillow/setup.py", line 305

    yield from self.features

             ^

SyntaxError: invalid syntax

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /tmp/pip_build_ubuntu/pillow
Storing debug log for failure in /home/ubuntu/.pip/pip.log
Warning: Failed to install all requirements. Continue? y/N

What can I do? Can I perhaps install the libraries one by one and modify the dev_setup.sh accordingly?

For reference:

ubuntu@tegra-ubuntu:~/mycroft-core$ pip --version
pip 1.5.4 from /usr/lib/python2.7/dist-packages (python 2.7)

Any help is much apprecaited, thanks!

Daniel

p.s. For the record I had these two other problems earlier:

  1. I initially kept getting “runtimeerror: python 3.5 or later is required” I figured that could be from pip not installed properly, so I did sudo apt install python-pip, that fixed it

  2. I kept getting “Failed to set up virtualenv for mycroft, existing setup” and after some digging I realised it’s because .venv/bin/activate scripts aren’t executable.

Hi,

the big issue here is probably the python version. Mycroft requires python3.5 or higher. Ther yield from error makes it sound like the python3 version available in Ubuntu 14.04 is < 3.3 (where the yield from syntax was introduced).

I think even if you get past this issue Mycroft will likely not run correctly on your machine.

Thanks! That’s a good pointer. I thought the .venv is supposed to take care of multiple python versions, I think I’ve seen python 2.7 and 3.x in the system but I’ll double check.

I think even if you get past this issue Mycroft will likely not run correctly on your machine.

So sad :sob: Why is that? Is it because of the ancient Ubuntu version? Thought I’ve seen a post saying Mycroft ran on Ubuntu 14.04.

This thread may also be helpful to you.

1 Like

If you upgrade the python version on the system it should run but you’ll need python3.5 or above.

Thank you so much! With your help I have finally got it installed, but when I try to start I’m stuck at one problem at the moment: Need help to run Mycroft on Ubuntu 14.04 - will be great to hear any suggestions, thanks!