AMZN Music Skill - testing and feedback


#1

This skill makes Mycroft play your Amazon music library as if its name was Alexa :wink:

  • “Hey Alexa Mycroft, play the song purple rain by prince on amazon music”
  • “Hey Mycroft, play the album 25 by adele”
  • “Hey Mycroft, play something by the foo fighters”
  • “Hey Mycroft, play some jazz”

How to install the AMZN Music Skill

  • Install the skill by

    • SSH into your Mycroft, then
      • mycroft-msm install https://github.com/domcross/amzn-music-skill.git
    • in case the requirements are not installed automatically you must perform the following
      • mycroft-pip install bs4 requests python-vlc
      • sudo apt-get install vlc
    • NOTE: this installs the VLC client on your machine which takes up to 250MB on your disk/sd-card
  • The AMZN Music Skill connects to to the Amazon Music Services
    For that you need an an Amazon Music account and a subscription of type “music unlimited” or “prime music” - even if you want to stream music from your own library only.

After the skill is installed you must provide your account information in one of following ways:

  1. Enter your login credentials at home.mycroft.ai > Skills > Amzn music
    WARNING: with this option your Amazon username and password will be stored in clear text
    i) on a server hosted by mycroft.ai and
    ii) in the skills ‘settings.json’ file.

  2. Run ./credentials.py in the skill directory /opt/mycroft/skills/amzn-music-skill.domcross and enter your login credentials there.
    This will store your credentials encoded & pickled in the file credentials.store - this option is recommended if you care for privacy (and security of your Amaz*n account).
    NOTE: file ‘credentials.store’ must be owned by mycroft:mycroft - either run credentials.py as user ‘mycroft’ or sudo chown mycroft:mycroft credentials.store afterwards.

NOTE: this skill uses the CommonPlayFramework, make sure to have skills mycroft-playback-control and mycroft-stop installed (normally they should as these are default-skills on most Mycroft platforms)

How to test the AMZN Music skill

  • Provide your Amazon Music credentials as specified above
  • uncheck option ‘Library only’ in the skills settings at home.mycroft.ai
  • Speak Hey Mycroft, play some jazz on amazon
  • Mycroft should play some jazz music

See above for more examples, by the way: German is supported too…

NOTE: this skill was tested on a Mycroft Mark-1 and a PiCroft with Google AIY Voice kit (both running Debian Jessie) and on Ubuntu 16.04 (running as guest OS in Virtualbox 5.1 on a MacOS host). Test results with any other OS and/or hardware platform are highly welcomed.

Where feedback on AMZN Music Skill should be directed at

Feedback on the skill should be provided through:


Music for Mycroft - What does the Community want?
#2

Anyone here who already tried this skill and would like to share his/her experience with it?


#3

I like your work, but dont have an AMZN music account…so cant test I think.


#4

Hi Dominik, great work getting this working for AMZN music.

I’ve never tried their music service before, but just noticed you can sign up for a 30 day free trial account. So if anyone is interested in testing this skill that is certainly an option. Just be sure to cancel your subscription before the end of 30 days if you don’t want to keep using it. I think they force you to have valid credit card details in your account to get started with the trial.


#5

I have a amazon music account and could try the skill later today…


#6

Skill loads for me, but I am unable to get it to authorize. Captcha makes it unusable for me. :frowning:


#7

I am not sure if I understand correctly as I am not aware where a Captcha is required for authorization. Probably you have to log in once on the Amazon Music website. I had to do that when trying to access the Amazon-API for the first time…


#8

The logs mention it. I had previously logged into amz music web site. There’s a closed issue on the repo, looks same as that.


#9

Alright! Nice skill, I’ve been waiting for this for a while!

First, when I installed the skill on my picroft, the apt-get deps didn’t install all the way because the package lists weren’t updated.I’ve submitted a pr on your GitHub repo which covers this.

Alright, once I finished installing the skill, I entered my credentials. This was no problem with credentials.py. However, when I say

  • Hey Mycroft, play some jazz.

He just responds with “I’m not sure how to play jazz.”


#10

What’s in the /var/log/mycroft/skills.log?


#11

Can you please check if you have the Playback Control Skill installed? (this should be a default skill on most platforms, but I want to make sure…)


#12

Play back control skill is installed. I looked at my logs and it seems like vlc can’t load a bit of the log:
[0194d6c0] vlcpulse audio output error: PulseAudio server connection failure: Connection refused


#13

I understand you are using PiCroft, but which Debian release: Jessie or Stretch?
Did you try rebooting?


#15

Sorry for the delay,
My Pi croft is running Stretch, and I’ve rebooted many times.
Sometimes, but not always, the captcha is complained about, yet no matter what, nothing I do lets me play music.


#16

Thanks for the response. I am afraid I still do not understand where the “captcha request” occurs. Can you share a screenshot or logfile?

And do you still see the vlcpulse audio output error that you have reported before?


#17

On the github repo, look in issues, check the closed one.


#18

Nope, I’m not getting any issues with Vlc now. Now all I see is sometimes the captcha request, but mostly, I see in the logs, the playback control skill searching for skills that could play that, but instead, failing.

If I have time, I’ll reinstall Picroft and give it another go.


#19

@baconator thanks for the pointer - i missed that one as it was immediately closed again…

The “Unable to handle captcha” exception is thrown by the AmazonMusic Python-library that I use. I have never experienced this error myself.

Maybe this has something to do with the region the Amazon-account is assigned to (I have a “EU” account).
@brrn what is your region?

Removing the .amazonmusic-cookies.moz.dat file from Mycroft’s homedir (for PiCroft this should be /home/mycroft/) could be worth a try as well.


#20

I’m in the US region. Is there something that I should change?
Deleting the cookie file didn’t help.


#21

hello, I’m in Italy, I set-up the Picroft and install amazon Skill, but I receive this error:

mycroft.skills.core:load_skill:164 - ERROR - Failed to load skill: amzn-music-skill.domcross

any Idea?

Thanks