Mark 1 location and timezone

I just setup a mark 1 and can’t get it to give me the time for my time zone. If I ask for the time in San Francisco then I get the right time. If I just ask for the time then it is 2 hours off. It also gives me inaccurate weather details. I assume the location is not right. I logged in to home and set the location for the device but that hasn’t made a difference. I sshed in and found a mycroft.conf file in the home folder and in etc. Which takes precedent? Will adding locations to it be enough or do I need to add the timezone too? If so how do I determine timezone offsets for pst?


I am having the same problem. I add my location on the web dashboard but it doesn’t change it on the Mark 1.

1 Like

Mark_1s think they are in Lawrence, Kansas. I’m on the east coast, and the time it gives me is and hour early (central time). If I ask it the for weather without specifying a location it’ll tell me about Lawrence KS.

I think this is a bug. Once shipped they are not in Kansas any more…


Lol nice , not in Kansas anymore

The Mycroft home settings web page only lets you set a timezone by adding your location. It appears that setting the pi user’s timezone has no affect.

pitty. that looked like an easy fix. I’ve tried adding location settings to the mycroft config file and using the web page, neither works.

Try this:
tail -f /var/log/mycroft*

Even when idle you should see requests to every minute
requests.packages.urllib3.connectionpool - DEBUG - “GET /v1/device/???/location HTTP/1.1” 200 896

And if you navigate to /opt/mycroft you’ll see web_config_cache.json with timezone code (and country/city/etc) all with unix epoch updated_at value.

Tailing the log does show a request every minute or so, but there is no web_config_cache.json in my /opt/mycroft folder just the skills folder the enclosure folder and the version.json.

having the same problem.

2017-07-05 04:27:51,708 - mycroft.configuration - WARNING - Failed to fetch remote configuration: ConnectionError(MaxRetryError("HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /v1/device//setting (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x75d4f8b0>: Failed to establish a new connection: [Errno -2] Name or service not known',))",),)
2017-07-05 04:27:51,708 - mycroft.configuration - INFO - Loading configuration: /etc/mycroft/mycroft.conf

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=51 time=86.3 ms
64 bytes from icmp_seq=2 ttl=51 time=85.5 ms
64 bytes from icmp_seq=3 ttl=51 time=93.9 ms

I am using ethernet cable to the back of the unit. in case that makes a difference.

did you solve this issue ?
As I have the exact same problem.

No. Changing on the web, via mycroft config nor pi configurations had any effect.

Run sudo dpkg-reconfigure tzdata from the comand line to set the correct time zone

1 Like

I tried “sudo dpkg-reconfigure tzdata”, but it did not fix the timezone offset. I even rebooted, and it was still telling me the wrong time, even though the date command via SSH showed me the right time.

What’s the correct way to set the timezone?

I also tried various commands to tell Mycroft the time zone, but these didn’t work either. (I didn’t expect they would, but I figured it couldn’t hurt to try… :wink: )

There are two places to set a timezone on the web. The correct way is to go to devices and then click on the device. There you can set the location. It might take a couple of minutes for the device to update.

(The other place that doesn’t affect your devices is under you account settings).

When I want to set the timezone on in the location field there is no option to save this location.
How would I set up the correct location for outside the US, for example germany?

I started typing the town (quite small town in the UK) and it auto completed the name. The separate button to save changes is now gone, so I assume it saves when you press the back button.

Note that whenever you revisit the settings (i.e. to check whether they were saved) you need to be patient. It seems to take a couple of seconds to retrieve all the previous/saved settings.

Problem solved…the firefox ESR Browser seams not to work. I installed Chromium and autocompletion worked for Germany and the “save”-button appeared. Thanks!

I downloaded the 8.20 version of the production image and installed it, 4 or 5 days ago.

Every time I try and go into the device on the web page to set the location for the device I get an error message that the servers are down and will be back up in no time, but they have not been up everytime I check.

Are the server going to be back online anytime soon?


Hello. We have been having issues server side. Currently at this time 8/24/2017 1:36 PM GMT, we are still experiencing issues with our backend.