Raspberry Pi 3 Model B+ Compatibility?


#1

I’m sure most people here noticed that a new Raspberry Pi model was announced yesterday.

It appears that the changes are pretty minor architecturally, though there are noticeable upgrades to the processor speed and wireless networking. Is Picroft compatible with the new hardware, and if I bought one and exchanged the Pi inside of my Mark I with one of these boards, would there be any upside/downside?


[RPi Model 3 B +] Picroft noob questions
Mycroft with Google AIY Voice kit disk image
Unable to boot PiCroft
#2

Short answer is we don’t know until we get a couple to test on :wink:


#3

Our first community member test is underway, more details soon!


#4

I have tested the new pi3 B+ using the picroft image. Unfortunately it doesn’t work as it looks like the new hardware is not supported under the old jessie image. raspberrypi.org have released a new raspbian distribution for the pi3 B+ but it is based on stretch. As of now mycroft doesn’t appear to run under stretch so I wouldn’t recommend rushing out to buy one of these new boards. For those wanting to try out mycroft but don’t have a pi yet, you will have to make a decision whether to buy an outdated board or wait and till there is a mycroft image that runs under stretch (or maybe the new hardware bits can be backported to jessie).

Note this is based on my experience YMMV,


[RPi Model 3 B +] Picroft noob questions
#5

Thanks for the information @aussieW. I’m probably going to pick one up anyway because I use one for a i3 workstation at work, and the PoE is just too tempting, but I’ll hold off on Mycroft based projects for the time being. I guess I can recycle my old work Pi into a Mycroft project once it’s free.


#6

Hi,
i’m a fresh newcomer to Mycroft,

I’ve just finished pairing an installation using Google AIY kit and a Pi 3 B+ running Raspbian (2018-03-13-raspbian-stretch-lite).
Nothing out of order in particular, and followed bits and pieces of info i could find onto the forum.
I’ll come back in the next days after i figure out skilling my new C3PO buddy here.

PS:
I could say official documentation for installing on Pi really lacks and the Linux section: this started a giggling session:
"Keeping Mycroft for Linux updated:
@TODO Not sure what the easiest way is to keep Mycroft for Linux updated - is it as simple as doing a git pull from the remote repo?"
wow.
can i help? at least to get you started. lulz


#7

Just for the record, I was able to get mycroft running on a pi3 B+ by upgrading the picroft distribution.


#8

@mariusrugan could you please give details as to how you got mycroft running under stretch lite? I would really love to try out the echo cancellation under pulseaudio 10.


#9

sure,

well, running is a bit an overstatement atm :D; STT functionality is not working but everything else is (e.g. cli commands are interpreted correctly). I’m using a piece of code from @tjoen which enables the button to act as a engine trigger - however audio is not interpreted. i’m pretty sure it’s mycroft.conf because i fiddled with it and when using “listener” it gave me a sample rate error.

As for the Google Voice HAT from Google AIY Kit, playback functionality is fine; recording functionality is fine;

i’m willing to put everything in a little bit more structured than this, but this is the starting point.

what problems did you exactly encounter ?


#10

I followed the script for building a picroft image (https://github.com/MycroftAI/enclosure-picroft/wiki/Script-for-building-Picroft-image) using the new stretch lite image but mycroft failed to start due to some ssl errors.


#11

Didn’t experience anything like that at all.

To simplify into some milestones:

  1. On a clean Debian Strech install, didn’t bother at all with anything else other than sys utilities needed (git vim etc) and prereqs mentioned by @tjoen.

  2. Get Google Voice Hat AIY mic & speaker to work; using Google’s repo scripts to make necessary changes to alsa & boot/config.txt.

  3. Install mycroft from git checkout. https://mycroft.ai/documentation/linux


#12

Thanks, I’ll give it a try. I don’t have an AIY hat, so I suppose I can just skip that step.

I’ll provide feed back on how I go.


#13

I just zig-zag-ed a bit the “building a picroft image” document and i came across what you mention as a ssl error.
I know i’m messing things up but i was going to clean-restart again anyway;

After installation via deb packages, on Stretch, i ran mycroft-audio-test which threw up a

`AttributeError: 'module' object has no attribute 'ssl'`

which doesn’t come up if i’m using the python virtualenv mycroft creates when doing the git install;

So the conclusion is that you might need some python modules installed which are not mentioned in the documentation.


#14

I believe that error is similar to what I was seeing. From memory I saw the error in the syslog, generated when the mycroft services were trying to start up. I have no idea which python modules might be required to fix it.


#15

I also ran into those ssl issues trying to build picroft on stretch… Plus there are some fixed python modules versions in the requirements.txt that needed to be changed manually.

I gave up in the end, even tried compiling python from source with ssl.

I later read somewhere that I should have tried using libssl1.0-dev and NOT libssl-dev, which installs open-ssl version 1.1 that is not compatible with curl etc.

Hope you get it to work.

grtz, Tjoen


#16

So, in regards of using picroft packages; i gave it some time and a lot of love :), but it doesn’t work. The system becomes a huge mess (https://github.com/MycroftAI/mycroft-core/issues/1285; https://github.com/MycroftAI/mycroft-core/issues/382)
As referenced in the github issue, wonder what are the plans for addressing some of the entangled issues because RPI3 B+ doesn’t work with Debian Jessie ootb so it’s kind of complicated even for willing professionals to figure out a way.

EDIT: i stumbled across a report in early 2016 about these issues. That’s like… 2 years ago


Wonder what the @steve.penrod would say ?

I’ll restart the quest on installing it from sources.


#17

to answer your questions:
zero compatibility due to (software related) entangled issues. :slight_smile:


#18

@mariusrugan, could it be dockerized? It looks like there are a couple Jessie images that could be used as the base.

Since it’s likely to come up: https://stackoverflow.com/questions/21889053/what-is-the-runtime-performance-cost-of-a-docker-container.


#19

I’m also getting the ssl error on Stretch “`AttributeError: ‘module’ object has no attribute ‘ssl’” when
building a picroft image.

In my case, I have the Matrix Voice working great with the Stretch kernel but can’t install Mycroft
because of the ssl issue.


#20

Couple of things here;

We’re tracking this as an Issue here;

and it also appears to be a bug in the Python OpenSSL implementation;
http://debian-bugs-dist.debian.narkive.com/EF3Ba3Y3/bug-843631-attributeerror-module-object-has-no-attribute-ssl-st-init